[NTG-context] pgfplots broken?

luigi scarso luigi.scarso at gmail.com
Wed Nov 5 09:14:48 CET 2014


On Wed, Nov 5, 2014 at 8:42 AM, Akira Kakuto <kakuto at fuk.kindai.ac.jp>
wrote:

> Dear Mikael,
>
> An example from PGFPlots Gallery.
> Please try if it works. Here on windows, it seems to work.
> Attached files are tt.log.txt and tt.pdf.
>
> Best,
> Akira
>
> %
> % tt.tex: from PGFPlots Gallery
> %
> \setupcolors[state=start]
> \usemodule[tikz]
> \usemodule[pgfplots]
>
> \starttext
>
> \midaligned{%
> \starttikzpicture
> \startaxis[
> xmin=-3, xmax=3,
> ymin=-3, ymax=3,
> extra x ticks={-1,1},
> extra y ticks={-2,2},
> extra tick style={grid=major},
> ]
> \draw[red] \pgfextra{
> \pgfpathellipse{\pgfplotspointaxisxy{0}{0}}
> {\pgfplotspointaxisdirectionxy{1}{0}}
> {\pgfplotspointaxisdirectionxy{0}{2}}
> % see also the documentation of
> % 'axis direction cs' which
> % allows a simpler way to draw this ellipse
> };
> \draw[blue] \pgfextra{
> \pgfpathellipse{\pgfplotspointaxisxy{0}{0}}
> {\pgfplotspointaxisdirectionxy{1}{1}}
> {\pgfplotspointaxisdirectionxy{0}{2}}
> };
> \addplot [only marks,mark=*] coordinates { (0,0) };
> \stopaxis
> \stoptikzpicture
> }
>
> \stoptext
>
it's ok with TL 2014 (and the latest luatex from experimental),
that has
\def\pgfversion{3.0.0}
and it should be the
http://sourceforge.net/projects/pgf/



but
downloading the pgf module from  the garden


lua error       > error on line 75 in file
/opt/luatex/standalone-mkiv-new-I/tex/texmf/tex/generic/pgf/libraries/luamath/pgflibraryluamath.code.tex:

...iv-new-I/tex/texmf-context/tex/context/base/util-lib.lua:246: module
'pgfluamath.functions' not found:
        no field package.preload['pgfluamath.functions']
        no file '/usr/local/share/lua/5.2/pgfluamath/functions.lua'
        no file '/usr/local/share/lua/5.2/pgfluamath/functions/init.lua'
        no file '/usr/local/lib/lua/5.2/pgfluamath/functions.lua'
        no file '/usr/local/lib/lua/5.2/pgfluamath/functions/init.lua'
        no file './pgfluamath/functions.lua'
        no file '/usr/local/lib/lua/5.2/pgfluamath/functions.so'
        no file '/usr/local/lib/lua/5.2/loadall.so'
        no file './pgfluamath/functions.so'
        no file '/usr/local/lib/lua/5.2/pgfluamath.so'
        no file '/usr/local/lib/lua/5.2/loadall.so'
        no file './pgfluamath.so'
stack traceback:
        [C]: in function 'savedrequire'
        ...iv-new-I/tex/texmf-context/tex/context/base/util-lib.lua:246: in
function 'require'
        [\directlua]:1: in main chunk

65       \let\pgfutil at directlua\directlua
66       \pgfutil at directlua{%
67         tex.enableprimitives('pgfutil@',{'luaescapestring'})}
68     \else
69       \def\pgfutil at directlua#1{}
70       \def\pgfutil at luaescapestring#1{}
71     \fi
72
73     \pgfutil at directlua{%
74       pgfluamathfunctions = require("pgfluamath.functions")
75 >>    pgfluamathparser = require("pgfluamath.parser")}
76
77
78     % Patch some configuration macros such that the modifications are
79     % available in LUA as well:
80     \pgfkeys{
81      /pgf/trig format/deg/.add
code={}{\directlua{pgfluamathfunctions.setTrigFormat("deg")}\aftergroup\pgfmath at settrigformat
},
82      /pgf/trig format/rad/.add
code={}{\directlua{pgfluamathfunctions.setTrigFormat("rad")}\aftergroup\pgfmath at settrigformat
},
83     }
84     % ... and reactivate the key:
85     \pgfmathiftrigonometricusesdeg{%

and
\def\pgfversion{3.0.0-cvs}

So it seems that the cvs version is not ok with ctx
and I think that these
74       pgfluamathfunctions = require("pgfluamath.functions")
75 >>    pgfluamathparser = require("pgfluamath.parser")}
are also wrong in Lua .


-- 
luigi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20141105/94a1bf01/attachment.html>


More information about the ntg-context mailing list