[NTG-context] ConTeXt Standalone will not install

Jaroslav Hajtmar hajtmar at gyza.cz
Tue Oct 21 23:32:56 CEST 2014


Hello ConTeXist.
Some time ago I changed a installing TeX Live directly from version 2012 
to version 2014.
ConTeXt in this version TeX Live works seamlessly, but I have since 
stopped working update Standalone version. But I'm not entirely sure 
causation. Anyway, the update does not work as before. At first glance, 
it seems that the updates are performed correctly, but the files are not 
probably somehow eventually copied. I am not subsequently able to 
compile things that require the latest version of ConTeXt.
I must say that I am in a one moment delete the entire directory 
texmf-cache, because I began to discover a strange message about the 
mischmasch format of ConTeXt.

OK. Nothing to do. When I after a vain attempt failed ConTeXt update to 
the latest version, so I decided to ConTeXt Standalone completely 
re-install into my Windows 7 home edition. Installation failed, although 
I followed the instructions exactly to ConTeXtgarden 
(http://wiki.contextgarden.net/ConTeXt_Standalone). Creates only the TeX 
directory and there empty directories ("cache-texmf, texmf-fonts, 
texmf-local texmf and texmf-modules-project"). These directories do not 
contain any files. I attach below the log file during installation.

I tried a second installation method cited in ConTeXt ConTeXtGarden (see 
http://wiki.contextgarden.net/Simple_Windows_Installation).
Link to the installation file is broken (see 
http://minimals.contextgarden.net/setup/context-installer/ContextMinimalInstall.exe)

Can anyone advise what I'm doing wrong and why you can not install 
ConTeXt? Nowhere does not say anything about setting the path 
respectively next steps. Blame those problems installing TeX Live 2014?
Thanks for the advice.
Jaroslav Hajtmar

Here is log file from instalation:

receiving incremental file list
./
kpathsea620w64.dll
luatex.dll
mtxrun.dll
mtxrun.exe
mtxrun.lua

sent 22928 bytes  received 5501341 bytes  356404.45 bytes/sec
total size is 9371026  speedup is 1.70

mtxrun          | forcing cache reload
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/Users/Jaroslav  Hajtmar/texmf/web2c' from specification 
'home:texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on weird path 
'C:/context/bin' from specification 'selfautoloc:'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/share/texmf-local/web2c' from specification 
'selfautoloc:/share/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/share/texmf-dist/web2c' from specification 
'selfautoloc:/share/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/share/texmf/web2c' from specification 
'selfautoloc:/share/texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/texmf-local/web2c' from specification 
'selfautoloc:/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/texmf-dist/web2c' from specification 
'selfautoloc:/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/bin/texmf/web2c' from specification 'selfautoloc:/texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on weird path 
'C:/context' from specification 'selfautodir:'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/share/texmf-local/web2c' from specification 
'selfautodir:/share/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/share/texmf-dist/web2c' from specification 
'selfautodir:/share/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/share/texmf/web2c' from specification 
'selfautodir:/share/texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/texmf-local/web2c' from specification 
'selfautodir:/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/texmf-dist/web2c' from specification 
'selfautodir:/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/context/texmf/web2c' from specification 'selfautodir:/texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'$SELFAUTOGRANDPARENT/texmf-local/web2c' from specification 
'$SELFAUTOGRANDPARENT/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on weird path 
'C:/' from specification 'selfautoparent:'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/share/texmf-local/web2c' from specification 
'selfautoparent:/share/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/share/texmf-dist/web2c' from specification 
'selfautoparent:/share/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/share/texmf/web2c' from specification 
'selfautoparent:/share/texmf/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/texmf-local/web2c' from specification 
'selfautoparent:/texmf-local/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/texmf-dist/web2c' from specification 'selfautoparent:/texmf-dist/web2c'
resolvers       | resolving | looking for 'texmfcnf.lua' on given path 
'C:/texmf/web2c' from specification 'selfautoparent:/texmf/web2c'
resolvers       | resolving |
resolvers       | resolving | warning: no lua configuration files found
resolvers       | resolving | no texmf paths are defined (using TEXMF)
resolvers       | resolving |
mtxrun          | the resolver databases are not present or outdated
mtx-update      | state, loaded
mtx-update      |
mtx-update      | update, start
mtx-update      | available platforms:
mtx-update      | run, rsync -rpztlv -L 
contextgarden.net::'minimals/current/misc/setuptex/' 
'/cygdrive/C/context/tex/.'
mtx-update      | run, rsync -rpztlv -L --delete 
contextgarden.net::'minimals/current/base/tex/ 
minimals/current/base/metapost/ minimals/current/fonts/common/ 
minimals/current/fonts/other/ minimals/current/misc/web2c 
minimals/current/fonts/new/ minimals/current/fonts/old/ 
minimals/current/base/xetex/ minimals/current/fonts/new/' 
'/cygdrive/C/context/tex/texmf'
mtx-update      | run, rsync -rpztlv -L --delete 
contextgarden.net::'minimals/current/context/beta/' 
'/cygdrive/C/context/tex/texmf-context'
mtx-update      | run, rsync -rpztlv -L 
contextgarden.net::'minimals/current/bin/common/win64/ 
minimals/current/bin/context/win64/ minimals/current/bin/metapost/win64/ 
minimals/current/bin/man/ minimals/current/bin/luatex/win64/ 
minimals/current/bin/luatex/win64/ minimals/current/bin/pdftex/win64/ 
minimals/current/bin/luatex/win64/ minimals/current/bin/xetex/win64/' 
'/cygdrive/C/context/tex/texmf-win64'
mtx-update      | updating mtxrun for win64: rsync -t 
"/cygdrive/C/context/tex/texmf-context/scripts/context/lua/mtxrun.lua" 
"/cygdrive/C/context/tex/texmf-win64/bin/"
mtx-update      | run, rsync -t 
"/cygdrive/C/context/tex/texmf-context/scripts/context/lua/mtxrun.lua" 
"/cygdrive/C/context/tex/texmf-win64/bin/"
resolvers       | tds | no 'texmf-win64' under tree 'C:\context\tex'

When you want to use context, you need to initialize the tree with:

   C:\context\tex\setuptex.bat C:\context\tex

You can associate this command with a shortcut to the cmd prompt.

Alternatively you can add C:\context\tex\texmf-win64\bin to your PATH
variable.

If you run from an editor you can specify the full path to mtxrun.exe:

   C:\context\tex\texmf-win64\bin\mtxrun.exe --autogenerate --script 
context --autopdf ...





More information about the ntg-context mailing list