[NTG-context] Font (roboto) and math font - error

Zenlima post at zenlima.eu
Wed Aug 27 21:50:50 CEST 2014


Hi,

I am switching all my docs to the roboto font as I just like the
look of that font. During this I ran into a problem with \item:

	! Math error: parameter \Umathquad\displaystyle is not set.
	..
	l.26  \item h
           ere we list the points,

In my example: as soon I enable any of the two \definetypeface lines I
am running into that error.. even if I only enable the math font. 

Every hint is welcome :)

Here is my example to reproduce the error:

---8<------

\enableregime[utf]

\definefontfeature[fakesc][default][size=.8]

\starttypescript [sans] [roboto]
  \definefontsynonym[Sans][name:robotolight][fallbacks=Sans]
  \definefontsynonym[SansBold][name:robotoregular]
  \definefontsynonym[SansItalic][name:robotolightitalic] 
  \definefontsynonym[SansSlanted][name:robotolightitalic] 
  \definefontsynonym[SansBoldItalic][name:robotoregularitalic]
  \definefontsynonym[SansBoldSlanted][name:robotoregularitalic]
  \definefontsynonym[SansCaps] [name:robotolight][features=fakesc]
\stoptypescript 
\starttypescript [math] [latinmodern]
  \definefontsynonym[Math][name:latinmodernmathregular]
 \stoptypescript

\definetypeface[fliesstext][ss][sans][roboto]
\definetypeface[fliesstext][mm][math][latinmodern][default]

\setupbodyfont[fliesstext,ss,11pt]

\starttext
 \startitemize
 \item here we list the points,
 \item one after the other.
 \stopitemize
\stoptext


More information about the ntg-context mailing list