[NTG-context] weird interference in xml processing

Hans Hagen pragma at wxs.nl
Wed Aug 20 15:31:58 CEST 2014


On 8/20/2014 1:28 PM, Thomas A. Schmitz wrote:
> Hi,
>
> I encounter a weird interference when setting xml entities. Minimal example:
>
> \startbuffer[test]
> <a>
>    test ∼ test
> </a>
> \stopbuffer
>
> \startxmlsetups xml:testsetups
> 	\xmlsetsetup{\xmldocument}{a}{xml:*}
> \stopxmlsetups
>
> \xmlregistersetup{xml:testsetups}
>
> \startxmlsetups xml:a
> 	\xmlflush{#1}
> \stopxmlsetups
>
> \xmltexentity{sim}{\getglyph{name:texgyretermesmath}{\char"223C}}
>
> \starttext
> \xmlprocessbuffer{main}{test}{}
>
> \stoptext
>
> Instead of the expected symbol, I get a grave accent with recent context betas (it works with betas until mid-June). When I try the command \getglyph{name:texgyretermesmath}{\char”223C} in a normal context document, I get the expected output. What is happening here?

So what is the expected symbol?

  [0x223C]={
   adobename="tildeoperator",
   description="TILDE OPERATOR",

Hans


> All best
>
> Thomas
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
>
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________
>


-- 

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list