[NTG-context] Margin heading problem, was Re: sections

Rik Kabel context at rik.users.panix.com
Mon Jun 2 03:44:19 CEST 2014


On 2014-06-01 12:52, Hans Hagen wrote:
> On 6/1/2014 5:40 PM, Rik wrote:
>
>> Is this also the cause of problems I noted with heading placed into the
>> margin, as in the example below?
>
> no, unrelated, try this:
>
> \setuphead
>   [section]
>   [after={\strut\blank[-2*line,samepage,disable]},
>    command=\SectionCommand,
>    distance=0pt]
>
> \define[2]\SectionCommand{\inleft{XXXXXX}}

That was fine until it ran into \setupwhitespace with a non-zero value. 
Fiddling with the after key \blank does not appear to help.

    \define[2]\MarginHead{\inmargin{#1\\#2}}
    \setuphead    [section]
                   [command=\MarginHead,
                    distance=0pt,
                    after={\strut\blank[-2*line,samepage,disable]}]
    %% With no \setupwhitespace, or any \setupwhitespace setting that
    %%   results in zero interparagraph whitespace, all is well.
    %setupwhitespace      [none]%    okay
    %setupwhitespace      [fix]%     okay
    %% With non-zero interparagraph whitespace, the heading separates
    %%   from the text
    \setupwhitespace      [line]%    bad
    \starttext
    \startchapter[title={Weisman}]
      \input weisman\par
      \input weisman
    \startsection[title={Thuan}]
      \input thuan\par
      \input thuan
    \stopsection
    \stopchapter
    \stoptext

-- 
Rik Kabel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20140601/12fa7a21/attachment-0001.html>


More information about the ntg-context mailing list