[NTG-context] bug in \setuptagging?

Hans Hagen pragma at wxs.nl
Sat May 31 12:49:51 CEST 2014


On 5/31/2014 8:30 AM, Pablo Rodriguez wrote:
> Dear list
>
> I experience weird results with latest beta (2014.05.30 23:26).
>
> Here is the sample:
>
>      \setuppapersize[A6]
>      \setuptagging[state=start]
>      \setuptyping[margin=yes,align={right,broad}]
>      \starttext
>      \starttyping
>      \setuptyping[margin=yes, align={right,broad}]
>      \stoptyping
>      \stoptext
>
> If I disable \setuptagging, output is fine. But with \setuptagging
> enabled, the typing environment doesn’t display multiple lines.
>
> Am I doing something wrong or have I hit a bug?

The space in verbatim is defined differently because otherwise it can 
get lost in the export; you can experiment with:

\appendtoks
     \unexpanded\def\obeyedspace{\hskip\zeropoint\char32\hskip\zeropoint}%
\to \everyenableelements

and see if that is acceptable. Normally in exports context has some 
heuristic to add spaces in the output (also pdf) instead of skips but 
for verbatim this has to be more strict.

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list