[NTG-context] Undefined control sequence: setupresume

Bart Wise bart.c.wise+context at gmail.com
Thu Apr 3 04:10:30 CEST 2014


I am unable to compile anything using the resume module from Wolfgang's
t-letter package.
I had to put a symlink from t-cor-03.tex -> t-resume.tex

Here's the source:

\usemodule[resume][interface=moderncv,style=classic]
\starttext
Hello World!

\stoptext

Excerpts from the log file:

ConTeXt  ver: 2014.01.03 00:40 MKIV current

system          > 'cont-new.mkiv' loaded
(/home/bart/context/20140314-stable/tex/texmf-context/tex/context/base/cont-new.mkiv)
system          > files > jobname 'test', input './test', result 'test'
fonts           > latin modern fonts are not preloaded
languages       > language 'en' is active
(/home/bart/tmp/test.tex
resolvers       > modules > 'resume' is loaded
(/home/bart/texmf/tex/context/t-cor-03.tex
loading         > Context User Module / Framework for Resumes
resolvers       > modules > 'correspondence' is loaded
(/home/bart/texmf/tex/context/third/letter/base/t-correspondence.mkiv
loading         > Context User Module / Correspondence
)
correspondence  > loading 'resume' 'interface' 'moderncv.nri'
(/home/bart/texmf/tex/context/third/letter/interface/moderncv.nri
colors          > 'rgb' color space is supported
colors          > 'cmyk' color space is supported
correspondence  > loading 'resume' 'style' 'classic.nrs'
(/home/bart/texmf/tex/context/third/letter/style/classic.nrs
! Undefined control sequence.

system          > tex > error on line 191 in file
/home/bart/texmf/tex/context/third/letter/style/classic.nrs: Undefined
control sequence ...

181     \setupresumestyle
182       [\v!nextfoot]
183       [\v!layer]
184       [\c!preset=\v!left\v!bottom,
185        \c!hoffset=\backspace,
186        \c!voffset=2cm]
187
188     %D Default style for the user information
189
190     \setupresume[\v!quote]     [\c!style=\v!italic,\c!color=resume:4]
191 >>  \setupresume[\v!firstname] [\c!style=\c!tf\c!d,\c!color=resume:1]

I'm stumped.  I'm not sure which module "setupresume" is defined, unless
it's the t-resume.xml file.

What am I doing wrong?

Thanks,
Bart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20140402/c6323fcc/attachment.html>


More information about the ntg-context mailing list