[NTG-context] hyperlinks in latest beta?

Hans Hagen pragma at wxs.nl
Mon Mar 24 09:50:51 CET 2014


On 3/22/2014 8:44 PM, Alan Bowen wrote:
> Hans—there are still some odd failures in hyperlinking between components.
>
> At least in the following product file with two components, some links
> work (\reference), some only sometimes (\at) and others never (\in). The
> problem seems to be with labels.
>
> \startproduct LinkTest
> \setupinteraction[state=start]
> \component Test01
> \component Test02
> \stopproduct
>
> \startcomponent Test01
> \product LinkTest
>
> \reference[startknuth]{}\input knuth
> \page
> \input knuth\reference[endknuth]{}\footnote[knuth]{A note.}
>
> \section[new]{a title}
> \input ward
>
> \page[makeup]
> \stopcomponent
>
> \startcomponent Test02
> \product LinkTest
>
> \type{\reference}, pp..\  \at[startknuth]–\at[endknuth]
>
> \type{\in} using a label: \at[knuth]n\in[knuth] as well as \at[new] (ref
> to section).
>
>
> \page[makeup]
> \stopcomponent
>
> The links to labeled items work within a single document:
>
> \startcomponent Test03
> \setupinteraction[state=start]
>
> \section[new]{A title}
>
> text\footnote[test]{text.}
> \page
> reference to note: \at[test]n\in[test]
>
> reference to section: \at[new]
>
> \page[makeup]
> \stopcomponent

new beta ... hopefully better ...

Hans

-----------------------------------------------------------------
                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl
-----------------------------------------------------------------


More information about the ntg-context mailing list