[NTG-context] hyperlinks in latest beta?

Alan Bowen bowenalan03 at gmail.com
Sat Mar 22 20:44:23 CET 2014


Hans--there are still some odd failures in hyperlinking between components.

At least in the following product file with two components, some links work
(\reference), some only sometimes (\at) and others never (\in). The problem
seems to be with labels.

\startproduct LinkTest
\setupinteraction[state=start]
\component Test01
\component Test02
\stopproduct

\startcomponent Test01
\product LinkTest

\reference[startknuth]{}\input knuth
\page
\input knuth\reference[endknuth]{}\footnote[knuth]{A note.}

\section[new]{a title}
\input ward

\page[makeup]
\stopcomponent

\startcomponent Test02
\product LinkTest

\type{\reference}, pp.\  \at[startknuth]-\at[endknuth]

\type{\in} using a label: \at[knuth]n\in[knuth] as well as \at[new] (ref to
section).


\page[makeup]
\stopcomponent

The links to labeled items work within a single document:

\startcomponent Test03
\setupinteraction[state=start]

\section[new]{A title}

text\footnote[test]{text.}
\page
reference to note: \at[test]n\in[test]

reference to section: \at[new]

\page[makeup]
\stopcomponent


Alan


On Thu, Mar 20, 2014 at 10:52 AM, Alan Bowen <bowenalan03 at gmail.com> wrote:

> Hans--the links function as they should in today's beta.
>
> Many thanks!
>
> Alan
>
>
> On Thu, Mar 20, 2014 at 8:42 AM, Hans Hagen <pragma at wxs.nl> wrote:
>
>> On 3/20/2014 12:41 PM, Wolfgang Schuster wrote:
>>
>>>
>>> Am 20.03.2014 um 10:09 schrieb Hans Hagen <pragma at wxs.nl
>>> <mailto:pragma at wxs.nl>>:
>>>
>>>
>>>  On 3/20/2014 12:57 AM, Alan Bowen wrote:
>>>>
>>>>> Pablo, Hans--
>>>>>
>>>>> Just checked. The links are not working for me either in ConTeXt  ver:
>>>>> 2014.03.19 23:11 MKIV beta.
>>>>>
>>>>
>>>> simple example ...
>>>>
>>>
>>> \setupinteraction[state=start]
>>>
>>> \starttext
>>>
>>> Text\pagereference[test]
>>>
>>> \page
>>>
>>> \at{Page}[test]
>>>
>>> \stoptext
>>>
>>>  what binary do you use? luatex 0.79? what viewer?
>>>>
>>>
>>> - This is LuaTeX, Version beta-0.78.2 (TeX Live 2014/dev) (rev 4746)
>>> - Adobe Reader 11
>>> - The preview app for Macs
>>>
>>
>> can you send me the pdf with \nopdfcompression
>>
>> (works ok here so i want to see the difference)
>>
>>
>>
>> -----------------------------------------------------------------
>>                                           Hans Hagen | PRAGMA ADE
>>               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
>>     tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
>>                                              | www.pragma-pod.nl
>> -----------------------------------------------------------------
>> ____________________________________________________________
>> _______________________
>> If your question is of interest to others as well, please add an entry to
>> the Wiki!
>>
>> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/
>> listinfo/ntg-context
>> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
>> archive  : http://foundry.supelec.fr/projects/contextrev/
>> wiki     : http://contextgarden.net
>> ____________________________________________________________
>> _______________________
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20140322/2659891a/attachment-0001.html>


More information about the ntg-context mailing list