[NTG-context] Problem with Standalone

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Jan 15 14:47:43 CET 2014


On Wed, Jan 15, 2014 at 6:17 AM, Henman wrote:
>
> I am trying to load the standalone but have ran into a problem.
>
> Platform:  cygwin on Windows XP
>
> Here is what I did to try to get it all loaded and setup:
>
> #1 rsync -av rsync://contextgarden.net/minimals/setup/first-setup.sh .
>    sh ./first-setup.sh  || exit 3
>
> The following files are loaded:
>   receiving incremental file list
>         bin/
>         bin/cygiconv-2.dll
>         bin/cygwin1.dll
>         bin/kpathsea620.dll
>         bin/lua52.dll
>         bin/luatex.dll
>         bin/mtx-update.lua
>         bin/mtxrun.dll
>         bin/mtxrun.exe
>         bin/mtxrun.lua
>         bin/rsync.exe
>         bin/texlua.exe
>
>
>     When you want to use context, you need to initialize the tree by typing:
>
>     . /opt/context/tex/setuptex
>
> NOTE: there is no /opt/context/!!  It doesn't get loaded.
>
>
> Any ideas of what is wrong?  Any work around to get the proper tex directory contents?

We used to have cygwin-specific binaries, but dropped them after the
volunteer who built them has lost the interest.

Actually I would surprised if the distribution worked with cygwin
out-of-the-box now that those binaries have been removed (probably a
few years ago already) because we never tried to adapt any code, but I
guess that Akira's native windows binaries should work just as well
under cygwin's shell, so fixing this should be doable.

There are two steps involved in syncronisation. The script
first-setup.sh first determines the platform. In the good old days we
used:

    # cygwin
    CYGWIN*)
        case "$cpu" in
            i*86) platform="cygwin" ;;
            x86_64|ia64) platform="cygwin-64" ;;
            *) platform="unknown" ;;
        esac ;;

and recently switched to:

    CYGWIN*)
        case "$cpu" in
            i*86) platform="mswin" ;; # cygwin, if we ever get "native
cygwin binaries"
            x86_64|ia64) platform="mswin" ;; # cygwin-64, likewise
            *) platform="unknown" ;;
        esac ;;

The script then fetches files from
    rsync -rlptv rsync://contextgarden.net/minimals/setup/$platform/bin .
which apparently succeeds, but then the following step fails:

    mtxrun --script ./bin/mtx-update.lua --force --update
--context=beta --platform=$platform --texroot="$CONTEXTROOT" $@

If this step actually ever worked, it might be that Hans' recent fixes
to determine whether Windows is 64-bit or not, might have broken the
functionality.

In any case I'm almost sure that mtxrun fails to deliver proper
binaries. Is there really no other output to be seen?

Mojca


More information about the ntg-context mailing list