[NTG-context] Avoid system fonts

Jörg Hagmann joerg.hagmann at unibas.ch
Fri Jan 3 22:37:13 CET 2014


Ok, I replaced line 12213 in "tex/texmf-osx-64/bin/mtxrun" with:

ossetenv("OSFONTDIR","$HOME/context/beta/empty//")

and that works.  But I hope that the mess will be repaired before I have
to update.

Cheers, Jörg

Jörg Hagmann writes:

> Thank you, Mojca, but I am afraid you have to be more specific.
>
> I created a directory ~/context/beta/empty
> I put into .profile OSFONTDIR=Users/bonasa/context/beta/empty
> Starting the shell gives:
> $echo $OSFONTDIR
> Users/bonasa/context/beta/empty
>
> but:
>
> context myfile.tex
> gives
>
> fonts           > names > 'OSFONTDIR' specifies path '/Users/bonasa/Library/Fonts'
> fonts           > names > 'OSFONTDIR' specifies path '/Library/Fonts'
> fonts           > names > 'OSFONTDIR' specifies path '/System/Library/Fonts'
>
> ???
>
> Thanks, Jörg
>
>
> Mojca Miklavec writes:
>
>> On Fri, Jan 3, 2014 at 1:21 PM, Jörg Hagmann wrote:
>>> Loading the fonts (?) takes too much time -- or maybe the programme is
>>> stuck, I don't know because I interrupted after a very long time at:
>>>
>>> fonts           > names > globbing path '/System/Library/Fonts/**.ttf'
>>>
>>> How can I avoid that, I don't use system fonts.
>>>
>>> Sorry, searching the mail archive is not possible at the moment.
>>>
>>> Mac 10.7.5
>>> Context version 2013.11.05 09:50
>>
>> We just discussed that problem off-list. On my system it's the culprit
>> of /System/Library/Fonts/LastResort.ttf (you can check that with
>> "Inspect -> Open files and folders" in Activity Monitor). Taco will
>> probably modify LuaTeX a bit to avoid the problem.
>>
>> I managed to use
>>     export OSFONTDIR=/some/existing/empty/path
>> but someone probably also needs to figure out why ConTeXt is loading
>> that font in the first place.


More information about the ntg-context mailing list