[NTG-context] internal mptopdf converter skips some glyphs in labels

Sanjoy Mahajan sanjoy at olin.edu
Fri Aug 9 22:26:01 CEST 2013


The internal mptopdf converter in MkIV omit some glyphs in the labels.
Here's a minimal example (test.tex):

\starttext

\externalfigure[testfig.1][frame=on]
\blank
\externalfigure[testfig-1.pdf][frame=on]

\stoptext

And testfig.1 is produced by testfig.mp

beginfig(1)
label(btex $\Omega$ etex, (0,0));
currentpicture := currentpicture scaled 5;
endfig;
end

Here's testfig.1 to save a step in debugging:

%!PS
%%BoundingBox: -18 -18 18 18 
%%HiResBoundingBox: -17.98805 -17.0195 17.98798 17.0195 
%%Creator: MetaPost 1.803
%%CreationDate: 2013.08.09:1612
%%Pages: 1
%*Font: cmr10 49.81323 9.96265 0a:8
%%BeginProlog
%%EndProlog
%%Page: 1 1
 0 0 0 setrgbcolor
-17.98805 -17.0195 moveto
(\012) cmr10 49.81323 fshow
showpage
%%EOF

Then do:

  mptopdf testfig.1
  context test.tex
  xpdf test.pdf

The first framed box, using the internal mps->pdf conversion, is empty.
The second framed go, using the pdf file produced by mptopdf, correctly
contains \Omega.

With \enabletrackers[graphics.conversion,graphics.inclusion], the log
has the following lines, none of which seem to pinpoint the problem:

  graphics        > inclusion > checking conversion of 'testfig.1', fullname 'testfig.1', old format 'mps', new format 'pdf', conversion 'default', resolution 'default'
  graphics        > inclusion > no converter for 'mps' to 'pdf'
  [MP to PDF]
  graphics        > inclusion > checking conversion of 'testfig-1.pdf', fullname 'testfig-1.pdf', old format 'pdf', new format 'pdf', conversion 'default', resolution 'default'
  graphics        > inclusion > no converter for 'pdf' to 'pdf'
  graphics        > inclusion > new graphic, using hash 'testfig-1.pdf->1->crop->unknown->unknown->unknown->'

(Though I don't believe the "no converter for 'mps' to 'pdf'" diagnostic.)

This is with Context 2013.05.28 00:36 MKIV (TL2013 on Debian).

-Sanjoy


More information about the ntg-context mailing list