[NTG-context] Missing number error, related to setupcolumnsetlines

Lars Huttar lars_huttar at sil.org
Thu Apr 18 23:13:07 CEST 2013


Hello,
I've got a "Missing number error, treated as zero". I've whittled the
problem code down to this minimal example:

    \definecolumnset [abbcolumn] [n=2,distance=5mm,balancing=yes]

    \setupcolumnsetlines[abbcolumn][1][1][60]
    \setupcolumnsetlines[abbcolumn][1][2][60]

    \starttext
    \startcolumnset[abbcolumn]
    foo
    \stopcolumnset
    \stoptext


By contrast, if I remove the \setupcolumnsetlines commands, the error
goes away. (But I think I need those commands, in case the text has more
than 60 lines.)

Also, if I run the example shown on this page
http://wiki.contextgarden.net/Command/setupcolumnsetlines
which seems very similar to mine, it works fine; no errors.

Based on the latter working example, I tried adding the following to my
minimal example that fails:

	\switchtobodyfont[small]
or
	\setupcolumnsetstart[abbcolumn][1][1][1]
	\setupcolumnsetstart[abbcolumn][1][2][1]


but neither one solved the problem.

Here is more of the error output I received when running TeX on the
minimal example shown at the start of this email:

! Missing number, treated as zero.

system          > tex > error on line 8 in file minimalex-133.tex:
Missing number, treated as zero ...

 1     \definecolumnset [abbcolumn] [n=2,distance=5mm,balancing=yes]
 2
 3     \setupcolumnsetlines[abbcolumn][1][1][60]
 4     \setupcolumnsetlines[abbcolumn][1][2][60]
 5
 6     \starttext
 7     \startcolumnset[abbcolumn]
 8 >>  foo
 9     \stopcolumnset
10     \stoptext
11

<to be read again>
                   \otr:1:43
\OTRSETdoifcellelse ...er #1:\number #2\endcsname
                                                  \@EA
\secondoftwoarguments...
\@@ar@@1 ...ellelse {\mofcolumns }\columnlastcell
                                                  {\global \advance
\columnl...
\redoloop ->\expandrecursecontent
                                  \endofloop
<to be read again>
                   {
<inserted text>
                44
...
l.8 f
     oo
?



Here is some of the earlier output, include the version info:

> context --mode=windows,report,border --nomapfiles --verbose 
minimalex-133.tex

resolvers       | resolving | creating instance
resolvers       | resolving | variable 'SELFAUTOLOC' set to
'c:/texlive/2012/bin/win32'
...
resolvers       | resolving |
resolvers       | resolving | unknown configuration file
'C:/Users/huttarl/texmf/web2c/texmfcnf.lua'
resolvers       | resolving | unknown configuration file
'c:/texlive/2012/bin/win32/texmfcnf.lua'
...
This is LuaTeX, Version beta-0.70.2-2012080612 (TeX Live 2012/W32TeX)
 \write18 enabled.
(minimalex-133.tex

ConTeXt  ver: 2012.05.30 11:26 MKIV  fmt: 2013.3.11  int: english/english


Thanks for any help!

Lars



More information about the ntg-context mailing list