[NTG-context] bug in new beta

Xenia yoraxe at googlemail.com
Mon Mar 18 21:58:55 CET 2013


On 17.03.2013 11:34, Hans Hagen wrote:
> On 3/17/2013 5:24 AM, Jonathan Barchi wrote:
> 
>> Hans (mostly),
>>
>> I've seen that font error too, but it never seemed to cause problems
>> so I've been ignoring it after I realized that.
>>
>> What I did figure out is that it seems to throw that error the first
>> time it loads a new font - that is, the first time that a new (known
>> to mtxrun) font is actually used in a document and loaded into the
>> cache. The error seems to be due to luatex (? or whatever program does
>> this) trying to compile a .tma file from the cache into a .tmc file,
>> but the .tma file doesn't exist. I think it then goes to the .otf
>> file, loads it, and is OK.
> 
> Indeed. I fixed it. It has to do with a test for a tmc file (when we run
> luajittex I need to make sure that a tmb file is generated as these
> engines have a different bytecode format). I got rid of the message in
> the new beta.

Weird, because I still get this error with


$ context --version

mtx-context     | ConTeXt Process Management 0.60
mtx-context     |
mtx-context     | main context file:
/home/context/tex/texmf-context/tex/context/base/context.mkiv
mtx-context     | current version: 2013.03.18 18:49


More information about the ntg-context mailing list