[NTG-context] Font recognition with command "context", but not with command "texexec"

Wolfgang Schuster wolfgang.schuster at gmail.com
Sun Jul 29 09:34:24 CEST 2012

Am 28.07.2012 um 21:11 schrieb Martin Rimmler <martin.rimmler at googlemail.com>:

> Hi,
> this might be a very simple problem, but I tried to figure it out for some time now without success. Reading manuals, searching with Google, etc. did not help. So if it actually is very simple, I herewith apologize. I really tried to solve it without the mailing list.
> Here is the Problem:
> The command "texexec" ignores the bodyfont setup. When I process the following code
>     \setupbodyfont[gentium]
>     \starttext
>     This little text is enough to demonstrate the problem.
>     \stoptext
> with the command "texexec filename", the default font is used. Only when i use the command "context filename.tex", context uses the font gentium. 
> The gentium font is a truetype font and stored on my system under /usr/share/fonts.
> I use Linux Mint Debian Edition 201204. My .bashrc file contains the following line:
>     export OSFONTDIR="/usr/local/share/fonts;$HOME/.fonts;/usr/share/fonts"
> I use the standalone version of context with pdftex. The command \contextversion returns "2012.07.27 16:41", i.e. the time I last updated it.
> Using the mkiv switch did not help.
>     texexec mkiv filename
> Any comments are welcome.

For MkII you have to load the typescript file and the typescript yourself while for MkIV these two steps are done together with the \setupbodyfont command when the name for the typeface, typescript and file is the same (e.g. gentium and type-gentium).


This little text is enough to demonstrate the problem.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20120729/7cef05a7/attachment.html>

More information about the ntg-context mailing list