[NTG-context] gnuplot: `! Undefined control sequence.` with format specifier %

Paul Menzel paulepanter at users.sourceforge.net
Mon Dec 12 01:20:00 CET 2011


Am Montag, den 12.12.2011, 01:02 +0100 schrieb Mojca Miklavec:
> On Mon, Dec 12, 2011 at 00:51, Paul Menzel wrote:

> > I compiled gnuplot 4.5 from source (master) and got everything running.
> > Mojca, thank you so much!
> >
> > Trying the example from the gnuplot page in the Wiki [1]
> >
> >        \usemodule[gnuplot]
> >
> >        \setupGNUPLOT[terminal=mp,option=color]
> >
> >        % general settings for the whole document
> >        \startGNUPLOTinclusions
> >
> >           # you may use TeX commands to format the titles and axes
> >           set title '\bf Trigonometry'
> >           set xlabel '$x$'
> >           set ylabel '$y$'
> >           set format y '\%.1f'
> 
> This should have been without the backslash.
>
> In beginning the text was processed with TeX, not it is taken
> literally (% doesn't start the comment any more), so maybe it's a
> leftover from the very early days. I will check the wiki.

I see. Thank you. It does not complain anymore.

> > Actually I hope that it is since then upgrading would fix my issue. ;-)
> 
> ... however I still have some problems. For some reason ConTeXt only
> generates dvi files from metapost code which has never been the case
> before. I need to figure out what is going on.

I am also getting other errors now and even moving the ConTeXt file to a
new directory I keep getting this error from `mpost`.

        fonts           : using map file: original-ams-euler
        [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1] [1.1]
        [1.1] [1.1] [1.1] [1.1]
        systems         : end file gnup-gnuplot-1-mp-temp at line 130
        (/srv/filme/context/tex/texmf-context/tex/context/base/cont-err.mkii
        systems         : no file 'cont-sys.tex', using 'cont-sys.rme' instead
        ) )
        Output written on gnup-gnuplot-1-mp-temp.dvi (16 pages, 1360 bytes).
        Transcript written on gnup-gnuplot-1-mp-temp.log.
        TeXExec | runtime: 0.244803
        
        This is MetaPost, version 1.504 (kpathsea version 6.0.0)
        
        mpost: Not writing to .log (openout_any = p).
        ! I can't write on file `.log'.
        Please type another transcript file name:


Thanks,

Paul
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20111212/a3aa1f7a/attachment.pgp>


More information about the ntg-context mailing list