[NTG-context] MKIV strange results in Adobe Reader

Otso Helenius context at pi-xi.net
Sun Sep 11 16:48:40 CEST 2011


Hi,

I have now investigated the color errors in Adobe Reader further.
I produced a test PDF without simpleslides with MKIV (mtx-context | 
current version: 2011.09.10 12:55).

Here is the source:

\language[fi]
\setupcolors[rgb]
\usemodule[metafun]
\setupbackgrounds[page][background=color,backgroundcolor=black]
\startreusableMPgraphic{variympyrat}
vardef ColorCircle (expr method, factor, ca, cb, cc) =
save u, p ; path p ; p := fullcircle shifted (1/4,0);
image (fill p rotated 90 withcolor transparent(method,factor,ca); fill 
p rotated 210 withcolor transparent(method,factor,cb); fill p rotated 
330 withcolor transparent(method,factor,cc))
enddef;
draw ColorCircle ("normal", 1, cyan, magenta, yellow) xsized 6cm;
draw ColorCircle ("darken", .85, cyan, magenta, yellow) xsized 6cm;
currentpicture := currentpicture shifted (0,-6cm);
draw ColorCircle ("exclusion", 1, red, green, blue) xsized 6cm;
\stopreusableMPgraphic
\starttext
\startcolor[white]
\title{metafun}
\includeMPgraphic{variympyrat}
\title{svg}
\externalfigure[variympyrat.svg]
\title{png}
\externalfigure[variympyrat.png]
\stoptext

and here is the output:
https://pi-xi.net/share/context_reader_test.png
https://pi-xi.net/share/context_reader_test.pdf

You can also see the original files used in the test here:
https://pi-xi.net/share/variympyrat.png
https://pi-xi.net/share/variympyrat.svg

The gray background effect happens randomly even with only using svg 
images straight from inkscape.
When using png images, I noticed it happens more often when there are 
multiple layers in the png.
With metafun graphics, the image colors are messed up in addition to 
the gray background.

I would like to know:

a) How to avoid it with metafun, png AND svg graphics?
b) What is the cause (Adobe reader bugs? Errors in my source? Erroneous 
image files? ConTeXt bug?)

Best regards,
Otso Helenius


More information about the ntg-context mailing list