[NTG-context] “deo” patterns?

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed May 11 10:43:37 CEST 2011


On Wed, May 11, 2011 at 09:57, Philipp Gesang wrote:
> On 2011-05-11 <09:20:30>, Mojca Miklavec wrote:
>> On Mon, May 9, 2011 at 11:08, Hans Hagen wrote:
>> > On 6-5-2011 7:31, Philipp Gesang wrote:
>> >
>> >> Which makes context throw a “! Conflicting pattern ignored.”
>> >> error over here.
>> >>
>> >> Did something change? If so, this should be reflected on the
>> >> wiki. Thanks,
>> >
>> > fixed in next beta (mem problems under investigation but not critical here)
>>
>> It is still a problem for me.
>
> Seems to work here (btw. lots of thanks to Hans for the fix!).
> I’ve not had enough time to check the result but at least loading
> the “deo” patterns does not cause the error anymore.
>
> mtx-context     | current version: 2011.05.10 19:20
>
> This is LuaTeX, Version beta-0.71.0-2011051109 (rev 4257)

Maybe it's a different LuaTeX version. With the following it doesn't work:

This is LuaTeX, Version beta-0.70.0-2011050613 (rev 4250)
 \write18 enabled.
(de.tex

ConTeXt  ver: 2011.05.10 19:20 MKIV  fmt: 2011.5.11  int: english/english

system          > cont-new.mkiv loaded
(/Users/mojca/context/context-test4/tex/texmf-context/tex/context/base/cont-new.mkiv
system          > beware: some patches loaded from cont-new.mkiv
)
system          > de.top loaded
(de.top)
fonts           > latin modern fonts are not preloaded
languages       > language en is active
! LuaTeX error lang-deo.lua:1: unexpected symbol near '.'
stack traceback:
	[C]: in function 'dofile'
	...est4/tex/texmf-context/tex/context/base/lang-ini.lua:118: in
function 'loaddefinitions'
	...est4/tex/texmf-context/tex/context/base/lang-ini.lua:250: in
function 'getnumber'
	...est4/tex/texmf-context/tex/context/base/lang-ini.lua:271: in
function 'languagenumber'
	<main ctx instance>:1: in main chunk.

system          > tex > error on line 13 in file de.tex: LuaTeX error  ...

I just realized that apparently fetching files from FTP didn't work,
so I was using the version from 9th May earlier. But none of the two
works here. I could try with a more recent luatex version though.

Mojca


More information about the ntg-context mailing list