[NTG-context] Latest beta not working.

Bart Wise bart.c.wise+context at gmail.com
Fri May 6 22:12:48 CEST 2011


If I run "context" with no arguments, I get the following output (and
nothing else):

mtxrun          | unknown script 'context.lua' or 'mtx-context.lua'


The file, mtx-context.lua does exis:

/home/bwise/context/20110505-beta-extras/tex/texmf-context/scripts/context/lua/mtx-context.lua



If I do an strace, it's looking for the following:

26155 open("./context.lua", O_RDONLY)   = -1 ENOENT (No such file or
directory)
26155
open("/home/bwise/context/20110505-beta-extras/tex/texmf-linux-64/bin/mtx-context.lua",
O_RDONLY) = -1 ENOENT (No such file or directory)
26155 stat("mtx-context.lua", 0x7fffcf962660) = -1 ENOENT (No such file or
directory)
26155 stat("mtx-context.lua", 0x7fffcf962660) = -1 ENOENT (No such file or
directory)
26155
open("/home/bwise/context/20110505-beta-extras/tex/texmf-linux-64/bin/mtx-context.lua",
O_RDONLY) = -1 ENOENT (No such file or directory)
26155 stat("context.lua", 0x7fffcf962660) = -1 ENOENT (No such file or
directory)
26155 stat("context.lua", 0x7fffcf962660) = -1 ENOENT (No such file or
directory)


So it's looking for the mtx-context.lua file in the
path: tex/texmf-linux-64/bin/mtx-context.lua
And it's really located in the
path: tex/texmf-context/scripts/context/lua/mtx-context.lua

Am I doing something wrong?

Thanks,
Bart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20110506/d59a66be/attachment.html>


More information about the ntg-context mailing list