[NTG-context] externalfigure error in current mkiv beta

luigi scarso luigi.scarso at gmail.com
Tue Apr 19 14:26:05 CEST 2011


On Tue, Apr 19, 2011 at 2:06 PM, Lutz Haseloff
<lutz.haseloff at googlemail.com> wrote:
> Hi all,
>
> with the current Context beta
> ConTeXt  ver: 2011.04.13 09:23 MKIV  fmt: 2011.4.19  int: english/english
> and a recent luatex
> LuaTeX, Version beta-0.66.0-2011041617 (rev 4160) (Win 7 64bit)
>
> the externalfigure macro breaks with following message:
>
> metapost        > loading 'metafun.mp' (experimental metapost version two)
> metapost        > terminal: >> picture
> ! Isolated expression.
> <to be read again>
>                   ;
> <*> externalfigure "hacker.png" ;
>                                  ;
>
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal: [1]
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal:
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal:
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal: (Please type a command or say `end')
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal:
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal:
>
> metapost        > error: unknown, no error, terminal or log messages
> metapost        > terminal: >> picture
> ! Isolated expression.
> <to be read again>
>                   ;
> <*> externalfigure "hacker.png" ;
>                                  ;
>
> My code:
>
> \starttext
> \startMPcode
> externalfigure "hacker.png" ;
> \stopMPcode
> \stoptext
confirmed
-- 
luigi


More information about the ntg-context mailing list