[NTG-context] LinearShade trouble

Kumar Appaiah a.kumar at alumni.iitm.ac.in
Wed Mar 30 08:59:14 CEST 2011


Dear Hans,

On Wed, Mar 30, 2011 at 08:48:15AM +0200, Hans Hagen wrote:
> >I have been having troubles with LinearShade with ConTeXt for quite a
> >while, even with the latest version.
> >
> >Steps to reproduce:
> >There is a test.tex at the bottom of this e-mail:
> >http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=580447#5
> >
> >Copy paste it into the ConTeXt Live interface at the ConTeXt
> >Garden. Result is blank.
> 
> best post the minimal example here and tell us what version you run;
> the benchmark is context mkiv as of today (not much has changed in
> mkii anyway)

Thanks. Here's the code:

<file>
\setuppapersize[S6][S6]
\setuppagenumbering[state=stop]
\switchtobodyfont[modern,20pt]
\setupcolors[state=start]
\setupbackgrounds[page][background=color,backgroundcolor=darkblue]
\startcolor[white]
\setuptolerance[verytolerant,stretch] 
\definecolor[a][r=0,g=0,b=1]
\definecolor[b][r=0,g=0,b=0.05]

\startuniqueMPgraphic{LinearShade}
path p ;
p := unitsquare xscaled \overlaywidth yscaled \overlayheight ;
linear_shade(p,6,\MPcolor{a},\MPcolor{b}) ;
\stopuniqueMPgraphic

\defineoverlay[shaded][\useMPgraphic{LinearShade}]

\setupbackgrounds[page][background={shaded}]
\starttext

Here's my first presentation in \CONTEXT!

Isn't it amazing?

\stoptext
</file>

This is from an old ConTeXt example I copied from your documentation
(I don't recall exactly).

Thanks!

Kumar
-- 
Kumar Appaiah


More information about the ntg-context mailing list