[NTG-context] (RSFS) font installation

mathew meta at pobox.com
Fri Mar 18 17:01:42 CET 2011


On Fri, Mar 18, 2011 at 09:51, Hans Hagen <pragma at wxs.nl> wrote:
> On 18-3-2011 3:40, mathew wrote:
>> \definetypeface [dingbats][ss][sans][dingbats][default]
>
> this assumes a dingbats typescript

Sorry, I omitted that when copying my code...

>> \starttext
>> {\dingbats \uchar{39}{7}\uchar{39}{13}\uchar{39}{42}}
>> \stoptext
>
> {\getnamedglyphdirect{dingbats}{0x39}}

\starttypescript [sans][dingbats][name]
  \definefontsynonym [Sans][name:dingbats]
\stoptypescript
\definetypeface [dingbats][ss][sans][dingbats][default]
\starttext
{\getnamedglyphdirect{dingbats}{0x272a}}

Or here's the character directly: ✪
\stoptext

...still not working. But KCharSelect says that the Dingbats font has
a glyph at 0x272a.

fonts           > fallback modern rm 12pt is loaded
system          > begin file makeup.tex at line 5
fonts           > defining > font with asked name 'dingbats' is not
found using lookup 'file'
fonts           > defining > unknown font dingbats, loading aborted
fonts           > defining > unable to define dingbats as \**currentsymbolfont**
backend         > xmp > using file
'/usr/local/context/tex/texmf-context/tex/context/base/lpdf-pdx.xml'

And yet if I run mtxrun --script fonts --list --all --pattern=* | grep dingbats
immediately after that ConTeXt run, in the same shell session, I see:
dingbats                             dingbats
/usr/share/fonts/type1/gsfonts/d050000l.afm
dingbatsnormal                       dingbats
/usr/share/fonts/type1/gsfonts/d050000l.afm

Also doesn't work if I reference the afm file directly using
  \definefontsynonym [sans][/usr/share/fonts/type1/gsfonts/d050000l.afm]


mathew


More information about the ntg-context mailing list