[NTG-context] (RSFS) font installation

Stefan Müller warrence.stm at gmx.de
Thu Mar 17 17:53:56 CET 2011


So... I think I got somewhere now with the explanations from you and mathew.

It seems that the problem were the missing .afm files (as mtxrun wanted 
those, not .pfm nor .pfb). I found two different solutions A and B:

(1) Install fonts (.pfm) in Windows

(2A) Put .afm files to C:\Windows\Fonts
(2B) Put the complete rsfs (containing the .afm and all the other stuff) 
directory to texmf-fonts\fonts

(3) Run "mtxrun --script fonts --reload"

(4) Running "mtxrun --script fonts --list --all --pattern=rsfs" shows 
the fonts
(Note the "--all", otherwise only one is printed)

There are two things now, that are somehow strange to me:

- In both versions, step (1) seems to be mandatory. I would expect, that 
the rsfs directory in texmf-fonts\fonts should be enough, as mtxrun 
clearly searches there and all the files are there, too. I don't 
understand the problem here.

- If the .pfm and .pfb files are sufficient for Windows, why does mtxrun 
specifically search for .afm files and not also for .pfm?

Anyhow, the fonts are finally listed/recognized by mtxrun. 
Unfortunately, the example at 
http://archive.contextgarden.net/message/20100414.122529.bc3ba584.en.html still 
doesn't show me the rsfs font, only a default font. Probably I just have 
to look into that (and the example from mathew) tomorrow.

Best regards and thanks so far,
Stefan.


More information about the ntg-context mailing list