[NTG-context] \setupalign[hz,hanging] breaks verbatim text

C. metan0r at gmx.de
Wed Feb 16 18:48:57 CET 2011


I have a strange problem in one of my documents.
When I uncomment the line with \setupalign[hz,hanging] everything works
fine. When I use it, I get this error because of a verbatim typing segment:

\obeyedline ->\par 
                   
\doverbatimendofline ->\dostoptagged \obeyedline 
                                                 \par \ifconditional
\verbat...
l.10 \dodisplayverbatimstop
                           
\ctxcommand ...\directlua \zerocount {commands.#1}
                                                  
\dodotypeblockverbatim ..., nature = "display", }}
                                                  \dostoptagged
\endofverbat...
l.71 \stoptyping
                
!  ==> Fatal error occurred, no output PDF file produced!
mtx-context     | fatal error: return code: 1

Here is the troublemaker:
\starttyping
test;
äüöAR \test \Context
\stoptyping

Interestingly I was not able to produce a real minimal example, because when
I remove everything except these lines, it’s working fine again. So there
has to be at least some lines of text to break stuff. Oh yeah, and it seems
that using simplefonts and Minion also plays a role.
Can somebody have a look at this, please? The attached file like it is does
not compile here.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: minimal.tex
Type: application/octet-stream
Size: 756 bytes
Desc: not available
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20110216/63276158/attachment.obj>


More information about the ntg-context mailing list