[NTG-context] error updating beta WAS: beta

Hans van der Meer H.vanderMeer at uva.nl
Wed Feb 2 20:07:18 CET 2011


More experiments, I am not one to be so easily defeated by software.
Retrieved some old beta's, each time I start a context run then it results in the loadfilemarkerror.
But I can find several formats lying around:
/Users/hans/TeX/ConTeXt/beta/tex/texmf-cache/luatex-cache/context/c180539b697aa06758debbc1182817e4/formats/cont-en.fmt
/Users/hans/TeX/ConTeXt/beta/tex/texmf-cache/luatex-cache/context/c180539b697aa06758debbc1182817e4/formats/cont-nl.fmt
/Users/hans/TeX/ConTeXt/beta/tex/texmf-osx-64/web2c/pdftex/cont-en.fmt
/Users/hans/TeX/ConTeXt/beta/tex/texmf-osx-64/web2c/pdftex/cont-nl.fmt
/Users/hans/TeX/ConTeXt/beta/tex/texmf-osx-64/web2c/xetex/cont-en.fmt
/Users/hans/TeX/ConTeXt/beta/tex/texmf-osx-64/web2c/xetex/cont-nl.fmt
Apparently none of them found! Vide this first message:
MTXrun | warning: no format found, forcing remake (commandline driven)

Here for inspection my .bashrc settings relevant to TeX. Could there be something amiss with these?
# TeX
export TEXLIVE=/usr/local/texlive/2010
export TEXPRIVATE=$HOME/TeX/My-TeXLib
export TEXMINIMAL=$HOME/TeX/ConTeXt/beta
export TEXPATH=$TEXMINIMAL/tex/texmf-osx-64/bin
export TEXMFDBS=$TEXMINIMAL
#$TEXMINIMAL/tex/setuptex
export TEXMF=$TEXMINIMAL
Note: inserting the hashed out line doesn't make a difference.

I append here the full terminal output below, just in case. 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.zip
Type: application/zip
Size: 2025 bytes
Desc: not available
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20110202/d2e5049e/attachment.zip>
-------------- next part --------------

Hans van der Meer


On 2 feb 2011, at 18:21, Hans van der Meer wrote:

> More weird things I am afraid. Experimenting somewhat, I removed the texmf-cahce and did mtxrun --generate.
> The first messages is: "/Users/hans/TeX/ConTeXt/beta"
> and its permissions are: "drwxrwxr-x  7 hans staff 238 2 feb 17:48 beta/"
> idem of the parent directory: "drwxr-xr-x  13 hans staff 442 2 feb 10:36 ../"
> 
> 120 beta: mtxrun --generate
> shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
> 
> Something wrong here? Something I can/should repair?
> 
> Hans van der Meer
> 
> 
> On 2 feb 2011, at 12:24, Hans van der Meer wrote:
> 
>> Did remove texmf-cache and ran mtxrun --generate. Still get on context --make en the error:
>> ! I can't find file `catc-ini.mkiv'.
>> <to be read again> 
>>                  \relax 
>> l.76 \loadmarkfile{catc-ini}
>> 
>> Please type another input file name: 
>> 
>> (will be away 1 or 2 hours, sorry not able to answer immediately)
>> Hans van der Meer
>> 
>> On 2 feb 2011, at 12:05, luigi scarso wrote:
>> 
>>> On Wed, Feb 2, 2011 at 11:57 AM, Hans van der Meer <H.vanderMeer at uva.nl> wrote:
>>>> Strange, doing (running MacOSX 10.6.6, beta is the directory in which context is installed):
>>>> 
>>>> 102 beta: mktexlsr
>>>> mktexlsr: Updating /Users/hans/TeX/ConTeXt/beta/ls-R...
>>>> mktexlsr: Done.
>>>> 103 beta: kpsewhich catc-ini.mkiv
>>>> /Users/hans/TeX/ConTeXt/beta/tex/texmf-context/tex/context/base/catc-ini.mkiv
>>>> 104 beta:
>>>> 
>>>> File is there. Checked again that "context --make en" runs into the same error.
>>> delete the cache and
>>> $> mtxrun --generate
>>> -- 
> 
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the Wiki!
> 
> maillist : ntg-context at ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
> webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
> archive  : http://foundry.supelec.fr/projects/contextrev/
> wiki     : http://contextgarden.net
> ___________________________________________________________________________________



More information about the ntg-context mailing list