[NTG-context] mptopdf (broken again)

luigi scarso luigi.scarso at gmail.com
Thu Jan 13 11:59:06 CET 2011


On Wed, Jan 12, 2011 at 6:12 PM, Mojca Miklavec
<mojca.miklavec.lists at gmail.com> wrote:
> 2011/1/12 Michal Kvasnička <prgosek at gmail.com>:
>> Hallo.
>>
>> I tried mtxrun --script mptopdf chart08.1 but I've got the following error.
>>
>> This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
>>  \write18 enabled.
>> entering extended mode
>> [MP to PDF]
>> (./charts08.1{/home/qasar/programy/context_stable/tex/texmf/fonts/m
>> ap/pdftex/plain/pdftex.map}) [1]
>> !pdfTeX error: pdftex (file lmmi9): Font lmmi9 at 600 not found
>>  ==> Fatal error occurred, no output PDF file produced!
>
> I have tried to compile the following example:
>
> beginfig(1);
> draw btex $x+1=2$ etex;
> endfig;
> end.
It seems related to mpost.



Saving this to mpost.map

lmmi10 LMMathItalic10-Regular "enclmmathit ReEncodeFont"
<lm-mathit.enc <lmmi10.pfb
lmmi12 LMMathItalic12-Regular "enclmmathit ReEncodeFont"
<lm-mathit.enc <lmmi12.pfb
lmmi5 LMMathItalic5-Regular "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmi5.pfb
lmmi6 LMMathItalic6-Regular "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmi6.pfb
lmmi7 LMMathItalic7-Regular "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmi7.pfb
lmmi8 LMMathItalic8-Regular "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmi8.pfb
lmmi9 LMMathItalic9-Regular "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmi9.pfb
lmmib10 LMMathItalic10-Bold "enclmmathit ReEncodeFont" <lm-mathit.enc
<lmmib10.pfb
lmmib5 LMMathItalic5-Bold "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmib5.pfb
lmmib7 LMMathItalic7-Bold "enclmmathit ReEncodeFont" <lm-mathit.enc <lmmib7.pfb
rm-lmr10 LMRoman10-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr10.pfb
rm-lmr12 LMRoman12-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr12.pfb
rm-lmr17 LMRoman17-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr17.pfb
rm-lmr5 LMRoman5-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr5.pfb
rm-lmr6 LMRoman6-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr6.pfb
rm-lmr7 LMRoman7-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr7.pfb
rm-lmr8 LMRoman8-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr8.pfb
rm-lmr9 LMRoman9-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmr9.pfb
rm-lmri10 LMRoman10-Italic "enclmrm ReEncodeFont" <lm-rm.enc <lmri10.pfb
rm-lmri12 LMRoman12-Italic "enclmrm ReEncodeFont" <lm-rm.enc <lmri12.pfb
rm-lmri7 LMRoman7-Italic "enclmrm ReEncodeFont" <lm-rm.enc <lmri7.pfb
rm-lmri8 LMRoman8-Italic "enclmrm ReEncodeFont" <lm-rm.enc <lmri8.pfb
rm-lmri9 LMRoman9-Italic "enclmrm ReEncodeFont" <lm-rm.enc <lmri9.pfb
rm-lmro10 LMRomanSlant10-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmro10.pfb
rm-lmro12 LMRomanSlant12-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmro12.pfb
rm-lmro17 LMRomanSlant17-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmro17.pfb
rm-lmro8 LMRomanSlant8-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmro8.pfb
rm-lmro9 LMRomanSlant9-Regular "enclmrm ReEncodeFont" <lm-rm.enc <lmro9.pfb

and test.mp

prologues:=3;
beginfig(1);
draw btex $x+1=2$ etex;
endfig;
end.

I have still an error

This is MetaPost, version 1.503 (kpathsea version 6.0.0)

mpost: Not writing to .log (openout_any = p).
! I can't write on file `.log'.
Please type another transcript file name:

Under linux I can bypass this error with

#>echo test | mpost  --jobname=test test.mp

The result eps has all the fonts subsetted.



-- 
luigi


More information about the ntg-context mailing list