[NTG-context] mptopdf (broken again)

Mojca Miklavec mojca.miklavec.lists at gmail.com
Wed Jan 12 18:12:10 CET 2011


2011/1/12 Michal Kvasnička <prgosek at gmail.com>:
> Hallo.
>
> I tried mtxrun --script mptopdf chart08.1 but I've got the following error.
>
> This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
>  \write18 enabled.
> entering extended mode
> [MP to PDF]
> (./charts08.1{/home/qasar/programy/context_stable/tex/texmf/fonts/m
> ap/pdftex/plain/pdftex.map}) [1]
> !pdfTeX error: pdftex (file lmmi9): Font lmmi9 at 600 not found
>  ==> Fatal error occurred, no output PDF file produced!

I have tried to compile the following example:

beginfig(1);
draw btex $x+1=2$ etex;
endfig;
end.

It works fine with TeX Live 2010/TLContrib, but fails in minimals
(nearly-latest version of ConTeXt).

To me this seems as if mptopdf was trying to run plain pdfTeX instead
of ConTeXt [or I have no idea what]. It then only reads pdftex.map
which certainly lacks the information about lmmi font. But I wonder
why it only reads from pdftex.map ... I could fix pdftex.map, but I
would like to figure out what exactly is going on ...

Mojca


More information about the ntg-context mailing list