[NTG-context] Trying MPtoPDF!

Verhaag, G.C.H.M. verhaaggchm at ziggo.nl
Sat Jan 8 10:54:53 CET 2011


Hi,

While trying to get some MetaPost plots converted to PDF, with the 
latest ConTeXt minimals installation (MkIV) on my Linux box, things 
happen which I don't understand, sorry!

First I run the command:

mtxrun --script

which yields:

MTXrun | TDS Runner Tool 1.26
MTXrun |
MTXrun | no script name given, known scripts:
MTXrun |
MTXrun | babel         1.20  Babel Input To UTF Conversion
MTXrun | base          1.35  ConTeXt TDS Management Tool
MTXrun | cache         0.10  ConTeXt & MetaTeX Cache Management
MTXrun | chars         0.10  MkII Character Table Generators
MTXrun | check         0.10  Basic ConTeXt Syntax Checking
MTXrun | context       0.51  ConTeXt Process Management
MTXrun | convert       0.10  ConTeXT Graphic Conversion Helpers
MTXrun | fonts         0.21  ConTeXt Font Database Management
MTXrun | grep          0.10  Simple Grepper
MTXrun | interface     0.11  ConTeXt Interface Related Goodies
MTXrun | metatex       0.10  MetaTeX Process Management
MTXrun | modules       1.00  ConTeXt Module Documentation Generators
MTXrun | mptopdf       0.51  MetaPost to PDF Converter
[more is output but NOT listed here!]

When I run

mtxrun --script mptopdf tobeconvertedplot.1

I get the following output:


This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
 \write18 enabled.

kpathsea: Running mktexfmt mptopdf.fmt
mktexfmt: No such file or directory
I can't find the format file `mptopdf.fmt'!

MPtoPDF 1.4.0 : error while processing tex file

By the way I've NO TeXLive installed!
Why do the MTtoPDF versions (1.4 or 0.5!) not agree, and why does it not 
work?

Do I need to install other tools to get it working?

Regards,
Gerard Verhaag


More information about the ntg-context mailing list