[NTG-context] problem with beta for linux-64

Vladimir Lomov lomov.vl at gmail.com
Sun Nov 14 18:23:51 CET 2010


Hi.
** Aditya Mahajan [2010-11-13 21:11:31 -0500]:

> On Sat, 13 Nov 2010, Erik Margraf wrote:
> 
>>I get the following error message while running first-setup.sh:
>>------------
>>! I can't find file `catc-ini.mkiv'.
>><to be read again>
>>                  \relax
>>l.42 \loadmarkfile{catc-ini}
>>-----------
>>
>>Strange enough, I find it as
>> ..../tex/texmf-context/tex/context/base/catc-ini.mkiv
>>
>>Anything I can do about that?
> 
> I had the same error. I am on linux-64 and the luatex binary in
> linux-64/bin did not have the execute permission set. So the wrong
> luatex was being used.
> 
> But I use mtx-update directly, so do not know if this is the same
> reason for the error in the minimals.
I could confirm that there is the problem with context minimal
installation on linux-64. The cause of the problem is missing permission
for executable.

Currently I could build the formats only if I split the actions: update
and make.

P.S. To ensure that the same problem would not arise in future the
'update' and 'make' procedures should be splitted and between them 'chmod
+x bin/texlua tex/texmf-linux-64/bin/luatex' (texmf-$platform) is 
inserted.

---
WBR, Vladimir.

-- 
Perfect day for scrubbing the floor and other exciting things.


More information about the ntg-context mailing list