[NTG-context] Running Mk-IV using TeXLive 2010

R (Chandra) Chandrasekhar chyavana at gmail.com
Wed Oct 6 19:19:27 CEST 2010


On Wednesday 06 October 2010 03:33 PM, Mojca Miklavec wrote:
> On Wed, Oct 6, 2010 at 04:07, R (Chandra) Chandrasekhar wrote:
>>
>> If I wanted to fix my broken TeXLive, should I just re-install ConTeXt from
>> the TeXLive 2010 DVD or should I do a full re-install of the full scheme?
>
> You have two options:
> a) finish what you started
> b) reinstall
>
> In case of reinstall, it should be enough if you reinstall context and
> luatex, I guess that can be done with:
>      tlmgr install --reinstall context luatex

> You will have some leftovers (extra files), but that should in general
> not be a problem. (You can try to delete (= first move to some other
> place) texmf-dist/tex/context before reinstalling if tmlgr won't
> complain too much about missing files that cannot be removed.)

Before I saw your reply I did the following:

1. mv /usr/local/texlive/2010/texmf-dist/tex/context /tmp

2. Installed the ConteXt scheme from the TeXLive 2010 DVD along with the 
following further customizations, just in case they had been altered:

Extra Fonts
Recommended Fonts
TeX and Outline Fonts
Extra Formats
LuaTeX packages

3. tlmgr update --self --all

4. luatools --generate
    context --make

The context from TeXLive 2010 works fine but texexec fails with this 
message:

---
ConTeXt  ver: 2010.07.30 11:35 MKII  fmt: 2010.10.5  int: english/english

system          : cont-new loaded
(/localhost/texlive/2010/texmf-dist/tex/context/base/cont-new.tex

FatalError      : Your format does not match the base files!
--

> If something goes very bad, you can of course always reinstall
> everything, but if the above works, there's no reason to worry.

It looks like that :-(

> If you want to finish what you have just started, you need to also
> sync mtxrun and fetch texmfcnf.lua from minimals and fix it according
> to TL structure. (That's slightly more non-trivial.) I almost forgot
> about that file when I said that one should also update mtxrun.

Wanting to have both context minimals and TeXLive 2010--modified only by 
tlmgr--coexisting, I tried to install the minimals in a directory called

~/local-context

using the following commands:

rsync -av rsync://contextgarden.net/minimals/current/context/current/ \
  ~/local-context/

rsync -av --include 'mtxrun' --include 'luatools' \
   rsync://contextgarden.net/minimals/current/bin/context/linux-64/bin/ \
         ~/local-context/bin/

I then set the following environment variables:

PATH=~/local-context/bin:$PATH; export PATH
OSFONTDIR=/usr/local/share/fonts:/usr/local/texlive/2010/texmf/fonts:$HOME/.fonts; 
export OSFONTDIR

Finally, I ran

luatools --generate
context --make
context --make cont-en
mtxrun --script fonts --reload

But I got errors about some files not being resolved and context was 
broken. So, I unset the environment variables, and just to be doubly 
sure, repeated steps 1 to 4 above, to get a working context (but not 
texexec) from TeXLive 2010.

If there is a complete error-free algorithm/script in future for making 
TeXLive 2010 and the context-minmals coexist independently I will 
appreciate knowing about it.

Meanwhile, it looks like I need to reinstall TeXLive 2010 afresh.

Thanks to everyone for all the explanations and help.

Chandra


More information about the ntg-context mailing list