[NTG-context] Ubuntu and Context MKIV

George N. White III gnwiii at gmail.com
Sat Aug 21 21:06:12 CEST 2010


On Sat, Aug 21, 2010 at 11:58 AM, Xan <dxpublica at telefonica.net> wrote:
> Al 21/08/10 00:30, En/na George N. White III ha escrit:
>>
>> O
>> When I run luatools --generate (as normal user) there are no errors.
>>
>> I don't have /etc/texmf/web2c/pdftex on my system.   On debian/ubuntu
>> /etc/texmf/web2c is for configuration files, but perhaps some program
>> tried to put formats and logs there instead of the proper /var/lib/texmf:
>>
>> $ locate texmf/web2c/pdftex
>> /var/lib/texmf/web2c/pdftex
>> /var/lib/texmf/web2c/pdftex/amstex.fmt
>> /var/lib/texmf/web2c/pdftex/amstex.log
>> /var/lib/texmf/web2c/pdftex/cont-en.fmt
>> /var/lib/texmf/web2c/pdftex/cont-en.log
>> /var/lib/texmf/web2c/pdftex/etex.fmt
>> /var/lib/texmf/web2c/pdftex/etex.log
>> /var/lib/texmf/web2c/pdftex/latex.fmt
>> /var/lib/texmf/web2c/pdftex/latex.log
>> /var/lib/texmf/web2c/pdftex/mptopdf.fmt
>> /var/lib/texmf/web2c/pdftex/mptopdf.log
>> /var/lib/texmf/web2c/pdftex/pdfetex.fmt
>> /var/lib/texmf/web2c/pdftex/pdfetex.log
>> /var/lib/texmf/web2c/pdftex/pdflatex.fmt
>> /var/lib/texmf/web2c/pdftex/pdflatex.log
>> /var/lib/texmf/web2c/pdftex/pdftex.fmt
>> /var/lib/texmf/web2c/pdftex/pdftex.log
>>
>
> So I don't know what have to do!!!

It is hard to say without more information.   You appear to
have a /etc/texmf/web2c/pdftex directory.   I suspect this
directory was created erroneously when making formats, in
which case it would contain .fmt and .log files.   This may mean
that one of the tools used to generate formats has a bug --
perhaps only triggered when run using the "root" account,
which is usually disabled on ubuntu, but this is
only conjecture.

If you have current hardware with ample disk and RAM
you could probably sort out the problem by installing a
fresh Ubuntu in a VM, repeating the steps you took to
get into this unhappy state but checking after each step
to figure out exactly when the configuration goes astray.
You can also experiment with various repair strategies
to see what works before trying to repair your main
installation.   I actually tried this, and was not able to
cause context to fail.   Using "sudo luatools --generate"
results in cache files that are owned by "root" but
still readable by a regular user.

Running luatools, fmtutil, etc. from "root" still didn't
produce /etc/texmf/web2c/pdftex so I'm at a loss to
figure out how that could happen.   It would be nice
to know how it happened so steps can be taken to
prevent others from ending up in the same predicament.

-- 
George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia


More information about the ntg-context mailing list