[NTG-context] Does Makempy still work?

Cedric Mauclair cedric.mauclair at gmail.com
Tue Aug 17 14:10:19 CEST 2010


I tried some other text and it appears that it can display (some)
maths, but no text.

graphictext "something" scaled 10 withdrawcolor red withfillcolor
green withpen pencircle scaled 2pt ;

doesn't work either.


P.S. : I am sorry, I just noticed the object of the message does not
start like the others.

-- Cédric



On Tue, Aug 17, 2010 at 10:55, Cedric Mauclair
<cedric.mauclair at gmail.com> wrote:
> I forgot to mention that the spacing is correct though nothing appears
> (file included).
>
> -- Cédric
>
>
>
> On Tue, Aug 17, 2010 at 10:53, Cedric Mauclair
> <cedric.mauclair at gmail.com> wrote:
>> I thought this would come with TeXlive or ConTeXt. It solved the
>> problem obviously, sorry for not trying it before calling for help.
>> Also, I removed "beginfig...endfig;" from the tex file.
>>
>> However, now I can only see "e mc". No "=" nor "2". Is there a special
>> version of pstoedit to install? I got mine from
>> http://www.helga-glunz.homepage.t-online.de/pstoedit/.
>>
>> -- Cédric
>>
>>
>>
>> On Tue, Aug 17, 2010 at 10:45, Hans Hagen <pragma at wxs.nl> wrote:
>>> On 17-8-2010 9:49, Cedric Mauclair wrote:
>>>>
>>>> Hi everybody,
>>>>
>>>> I tried to make a Metapost outline by following the mmakempy manual
>>>> but it didn't work. As I saw that "makempy" and "makempy.bat" files
>>>> were removed in 2010 (I don't remember the date), my question is: is
>>>> it still usable/valid feature?
>>>>
>>>> I processed the example from the manual, both from a standalone mp
>>>> file and a tex file (which follows):
>>>> \starttext
>>>> \startMPcode
>>>> input mp-grph ;
>>>>
>>>> beginfig(1) ;
>>>>   graphictext
>>>>     "$e=mc^2$"
>>>>     scaled 10
>>>>     dashed evenly
>>>>     withdrawcolor .7blue
>>>>     withfillcolor .7white
>>>>     withpen pencircle scaled 2pt ;
>>>> endfig ;
>>>> \stopMPcode
>>>> \stoptext
>>>>
>>>> It sucessfully created the test-mpgraph.pdf with the text processed by
>>>> TeX but the result page is blank, though it seems the "graphic" is on
>>>> a line by itself (seen from another document where all the lines go
>>>> down). When the mp file is processed with "mtxrun --script mptopdf",
>>>> it warns of a width and height of less than 1in when it tries to
>>>> convert from ps to pdf. When the tex file is processed with "mtxrun
>>>> --script context", it complains that metapost had a problem flushing a
>>>> literal and that it couldn't find pstoedit. Of course, this could be
>>>> the problem, but I have no idea of how I could get around this. By the
>>>> way, I use the TeXlive 2010 pretest.
>>>
>>>
>>> do you have pstoedit installed?
>>>
>>> -----------------------------------------------------------------
>>>                                          Hans Hagen | PRAGMA ADE
>>>              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
>>>    tel: 038 477 53 69 | voip: 087 875 68 74 | www.pragma-ade.com
>>>                                             | www.pragma-pod.nl
>>> -----------------------------------------------------------------
>>>
>>
>


More information about the ntg-context mailing list