[NTG-context] Problem with cross references

Thomas Schmitz tschmit1 at uni-bonn.de
Sat Aug 7 14:44:30 CEST 2010


On Sat, 7 Aug 2010 14:22:32 +0200
  Robert Blackstone <blackstone.robert at gmail.com> wrote:
> Hi all,
> I would like to get some advice concerning a problem, or 
>rather a
> nuisance, with internal references.
> I am making a longish document with several chapters, 
>all of which are
> separate .tex-files to be input into the main file, 
>which contains all
> setups and the skeleton of the document. There are a 
>number of cross
> references between elements that sit in different files.
> With some simple test files I checked that this worked 
>and that I use
> the proper commands.
> However, with the real files it does not work, that is, 
>not
> immediately. Even after 4 or 5 runs I still get ?? 
>instead of page
> numbers, and then suddenly things are OK. I have no idea 
>what happened
> between failure and success and I have no idea what I 
>have to do to
> get the proper result immediately.
> It is a nuisance because I cannot be sure the thing 
>worked till I have
> checked the entire output after each run, which is 
>rather time
> consuming.
> I’m using the latest version of TeXShop with the 
>minimals of july 20,
> but older versions show the same symptoms.
> Thanks for any advice.
> 
> Robert Blackstone
> 
Difficult to analyze, of course, but one thing that 
occurred to me: are you using a proper project structure, 
with the chapters as components, as described in chapter 
2.3 of the manual, or just using \input for the chapters? 
Right now, I'm editing a book (~ 300 pages) with 
cross-references between chapters, and I don't see any of 
the problems you describe.

Btw, the version of TeXshop is irrelevant to the problem, 
but you may want to update your minimals.

Thomas


More information about the ntg-context mailing list