[NTG-context] Float objects problem (was TABLE in Header ?)

Vnpenguin vnpenguin at vnoss.org
Mon Jul 19 12:25:27 CEST 2010


On Mon, Jul 19, 2010 at 09:21, Hans Hagen <pragma at wxs.nl> wrote:
> On 18-7-2010 4:14, Vnpenguin wrote:
>>
>> Hi,
>> It's possible to put TABLE within header ? I'm looking for an example
>> in Wiki but I can not found yet.
>
> sure, best put the table in a buffer and then call that buffer
>
> (actually, your page can be a table itself ... see example in page-plg.*)
>
> Hans
>

Thanks,
It works with TABLE within header. But I have another problem with
float image. In fact, I have a logo in a cell of my TABLE which is
found in header. Here is the code :
%%======================================================
\startsetups[myheader]
\bTABLE[setups=mytable-header]
\bTR
	\bTD[nr=2] \placefigure[here,force]{none}{\externalfigure[logo][width=22mm]}
\eTD
	\bTD {\tfb Foobar} \eTD
	\bTD[nr=2] Right1\\ Right2 \\ Right3	\eTD
\eTR
\bTR \bTD {\tfa Title \\ Sub-title} \eTD \eTR
\eTABLE
\stopsetups
\setupheadertexts[{\setups[myheader]}]
%%============================================

I got some page OK with this logo[1]. But there are also some bad
pages where I can not found my logo at all [2], or there are many logo
in the page [3].

Is this problem of float objects ? How to fix this ?

All files of my test are downloadable at : https://my.vnoss.net/pub/context/
ConTeXt source file : https://my.vnoss.net/pub/context/test.tex
PDF created by context : https://my.vnoss.net/pub/context/test.pdf

I use ConTeXt 2010.06.23 on Windows XP.

E:\tex> context --version

MTXrun | main context file:
C:/context/tex/texmf-context/tex/context/base/context.tex
MTXrun | current version: 2010.06.23 12:45

Thank you in advance,

Links:
[1] https://my.vnoss.net/pub/context/screenshot-ok.png
[2] https://my.vnoss.net/pub/context/screenshot-ko-1.png
[3] https://my.vnoss.net/pub/context/screenshot-ko-2.png


More information about the ntg-context mailing list