[NTG-context] Error in installing new beta (was: status message of mtxrun --ifchanged)

Aditya Mahajan adityam at umich.edu
Sun Jun 13 01:49:39 CEST 2010


On Sat, 12 Jun 2010, Hans Hagen wrote:

> On 11-6-2010 4:19, Aditya Mahajan wrote:
>> Hi,
>> 
>> When I run mtxrun --ifchanged, it echoes the status messages on stdout.
>> This makes it impossible to use mtxrun --ifchanged as part of a standard
>> unix pipe. What is the right way to resolve this?
>> 
>> * Output these messages to stderr rather than stdout?
>> * Provide a --silent option mtxrun that suppresses all output?
>> 
>> I can parse the generated output and remove the lines starting with
>> MTXrun, but that is no fun.
>
> after discussing it (as well as more generic suppresion message in the 
> engine) taco and i decided to go for --verbose instead
>
> new beta

Updating using first-setup.sh gives (also tried a fresh install, the same 
error)


sent 32402 bytes  received 7755726 bytes  65172.62 bytes/sec
total size is 30315844  speedup is 3.89
MTXrun | run: rsync -rpztlv 
contextgarden.net::'minimals/current/misc/setuptex/' '/tmp/context/tex/.'
receiving incremental file list
./
setuptex
setuptex.bat
setuptex.csh
setuptex.tmf

sent 109 bytes  received 6545 bytes  1209.82 bytes/sec
total size is 16420  speedup is 2.47
MTXrun | mtx update: updating mtxrun for linux-64: rsync -tgo --chmod=a+x 
/tmp/context/tex/texmf-context/scripts/context/lua/mtxrun.lua 
/tmp/context/tex/texmf-linux-64/bin/mtxrun
MTXrun | run: rsync -tgo --chmod=a+x 
/tmp/context/tex/texmf-context/scripts/context/lua/mtxrun.lua 
/tmp/context/tex/texmf-linux-64/bin/mtxrun
/tmp/context/bin/mtxrun:8497: bad argument #3 to 'format' (string 
expected, got no value)


I am on linux-64, if that matters.

Aditya


More information about the ntg-context mailing list