[NTG-context] updating context don´t work anymore on mac os x snow leopard

Mojca Miklavec mojca.miklavec.lists at gmail.com
Sun Jun 6 16:42:15 CEST 2010


On top of all that I also get (using an old mtx-update):

TeXExec | using mp engine mpost
TeXExec | using mps format path /Users/mojca/context/test/tex/texmf-osx-64/web2c
TeXExec | generating mps format metafun
This is MetaPost, version 1.211 (kpathsea version 6.0.0dev) (INIMP)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/metafun.mp
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-base.mp
Preloading the plain mem file, version 0.63)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-tool.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-spec.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-core.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-page.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-text.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-txts.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-shap.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-butt.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-char.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-step.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-grph.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-figs.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-mlib.mp)
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-grid.mp
(/Users/mojca/context/test/tex/texmf-context/metapost/context/base/mp-form.mp
! I can't find file `string'.
l.81 input string

Please type another input file name:

even though (when I go to a new terminal and set the path properly):

> kpsewhich string.mp
/Users/mojca/context/test/tex/texmf/metapost/base/string.mp


This is followed by

loading         : ConTeXt Backend Macros / PDF
)
! I can't find file `lpdf-pdx.mkiv'.
<to be read again>
                   \relax
l.90 \loadmarkfile{lpdf-pdx}
                             % might be merged into lpdf-ini

But this might only be a side-effect of something else (file exists).

It might be a bit difficult to reproduce - I'm using a slightly older
mtx-update.lua (but I can send it if anyone is interested).

Mojca


More information about the ntg-context mailing list