[NTG-context] Vim module errors

Adam C.M. Solove asolove at gmail.com
Fri Mar 19 02:14:57 CET 2010


Hi all,

Has anyone used the vim module recently and

I recently installed the third-party vim module for syntax highlighting in
my minimal install of ConTeXt MKIV/LuaTeX:

./first-setup.sh --extras="t-vim"
context --generate

I tried a minimal example from the manual:

\starttext
\usemodule [vim]
\definevimtyping [C]
[syntax=c,numbering=on]
\startvimcolorscheme [default]
\definevimsyntax [Type] [style=boldmono]
\definevimsyntax [PreProc] [style=slantedmono]
\stopvimcolorscheme
\startC
#include <stdio.h>
#include <stdlib.h>
void main() {
    printf("Hello World\n");
    return;
}
\stopC
\stoptext

You can see the ConTeXt live output (See full
output<http://live.contextgarden.net/output.cgi?id=dO7150>)
The problem is:

! I can't find file `texweb-vimsyntax.tmp-vimsyntax.tmp'.
<to be read again>

Looks like the filename munging has some issues.

Also, when I manually type in the correct file name, I then get further
errors which seem to indicate the source code is not within a literal
environment:

! You can't use `macro parameter character #' in horizontal mode.
l.1 #
     include <stdio.h>

I have vim installed and accessible on the path, and do have the C syntax.

I'm not TeXpert enough to troubleshoot the actual source, does anyone know
what might cause this behavior?

Thanks,

Adam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.ntg.nl/pipermail/ntg-context/attachments/20100318/12d48a13/attachment.html>


More information about the ntg-context mailing list