[NTG-context] MetaPost bug? in MKIV

Peter Rolf indiego at gmx.net
Tue Mar 2 19:42:22 CET 2010


Hi Troy,

I don't have the graph.mp file, but I have seen similar errors here. I
guess if you change the lines into

Gmargin.low:=-.07;
Gmargin.high:=1.07;

things work again. Sorry, I can't remember the reason why equations
cause trouble in mplib. But I'm quite sure that this is only an
incompatibility and not a bug.

Best wishes,  Peter

Am 02.03.2010 17:34, schrieb Troy Henderson:
> The following example produces expected output with MKII (texexec) but
> fails the compilation process with MKIV (context).
> 
> \startuseMPgraphic{foo}
>    input graph;
>    path p;
>    gdata("data.d", $, augment.p($1,$2););
>    draw begingraph(4in,2.5in);
>       gdraw p;
>    endgraph;
> \stopuseMPgraphic
> \starttext
>    \useMPgraphic{foo}
> \stoptext
> 
> 
> The data stored in data.d is as follows:
> 0  0
> 1  1
> 2  4
> 
> When compiling with MKIV, the following error occurs:
> 
> !mplib          : mp terminal:
> (/opt/context-minimals/tex/texmf/metapost/base/graph.mp
> ! Redundant equation.
> <to be read again>
>                    ;
> l.143 Gmargin.low=-.07;
>                                               % bbox fraction for default ra...
> 
> ! Redundant equation.
> <to be read again>
>                    ;
> l.144 Gmargin.high=1.07;
>                                               % bbox fraction for default ra...
> 
> )
> 
> !mplib          : mp error: unknown, no error, terminal or log messages
> !mplib          : mp terminal: [1]
> 
> !mplib          : mp error: unknown, no error, terminal or log messages
> 



More information about the ntg-context mailing list