[NTG-context] mpost finds BAD TFM

Hans van der Meer H.vanderMeer at uva.nl
Mon Dec 22 21:52:52 CET 2008

On 22 dec 2008, at 20:52, Aditya Mahajan wrote:

> On Mon, 22 Dec 2008, Hans van der Meer wrote:
>> A nasty problem has surfaced that Taco Hoekwater cannot solve,  
>> because it does not occur on his system. My system is Apple  
>> Macintosh 10.5.6 and I am using the command "sh build.sh" to  
>> compile metapost-1.101.
>> After compiling and generating with "mpost --ini mpost" the error  
>> message below result when calling "make" in the manual-directory of  
>> the distribution. It signals a bad tfm file, I guess because the  
>> wrong number of bytes is read. Some 16/32/64 bit issue perhaps?  
>> Taco has not found it and as his compile now runs "lint-free" it is  
>> difficult to imagine what can be wrong.
>> Are there people in this group (preferably on Macintosh) who find  
>> the same thing happening? And then are far more apt with debuggers  
>> than I am?
>> Many thanks in advance.
>> Hans van der Meer
>> This says the logfile of the mpost run, the programcode involved is  
>> from source file tfmin.w:
>> This is MetaPost, version 1.101 (kpathsea version 3.5.7) (mem=mpost  
>> 2008.12.22)  22 DEC 2008 17:53
>> **mpman
> Why is mpost 1.101 being used? The minimals have 1.110, so the  
> sources should be more recent. Could the error be due to something  
> wrong in the $PATH?
> Aditya
> ___________________________________________________________________________________

The answer is: I took the latest stable version dated december 11,  
2008 from http://foundry.supelec.fr/projects/metapost/ and that says  
1.101. I do not work with minimals and I avoid beta's too. But the  
version I tried above came from branch/1.1 in the svn repository and  
was tried because Taco requested it in relation to the above problem.

Hans van der Meer

More information about the ntg-context mailing list