[NTG-context] Problem with TSV tables

Hans Hagen pragma at wxs.nl
Wed Jun 11 13:26:38 CEST 2008

Mojca Miklavec wrote:
> On Wed, Jun 11, 2008 at 11:26 AM, Jan-Erik Hägglöf wrote:
>> Hi!
>> Life is much easier if everything is there, thanks it worked better.
>> Unfortunally it seems that the "heading" part not work as expected. Only
>> the first "values" line get the grey bg and bold font. You can see
>> attached files.
> You mean that you don't get this line?
>     Time; Decay per second; Errorlimits
> To be honest - I do not understand a single line in the database
> module. A really dirty future-incompatible workaround is to duplicate
> the line. The first one will be swallowed and the lecond one will be
> typeset, but that's a bug in the module. Hans? Taco? Why is the first
> line ignored?
> It worked OK some time ago, and nothing has changed in the module
> itself, so it's a complete mystery.
>> Thanks for helping me!
>> By the way... you did for a month ago send a working gnuplot module that
>> is working with Luatex. After a computercrash I lost it. Can you send
>> that once again??
> I guess this is the file I have sent you some time ago, but it doesn't
> work any more. I suspect that this portion of code is "broken" (LuaTeX
> doesn't create a new file any more), but I need to test before saying
> anything; it might be some completely reason:
> \doifmode{*\v!first}{
> 	\immediate\openout\scratchwrite=\GNUPLOTfile.plt
> 	\immediate\write\scratchwrite{set terminal
> \@@GNUPLOToutput\space\@@GNUPLOToptions}%
> 	\immediate\write\scratchwrite{load '\GNUPLOTfile.tmp'}%
> 	\immediate\closeout\scratchwrite
> }
> I wanted to say: "a dirty workaround is to run texexec with mkii
> before" since it does generate the file (mkiv doesn't) and then luaTeX
> would use that file, but even that seems to be broken now.
> Just in case that Hans can spot the reason of error, here it is, but I
> will try to find some minimal example to reproduce it.
> ! LuaTeX error ...text/tex/texmf-context/tex/context/base/luat-log.lua:74:
> invalid option '%C' to 'format'.

depends where the %C comes from ... maybe %%C works ok in the message

anyhow, i need to redo that module in lua i think


                                           Hans Hagen | PRAGMA ADE
               Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
      tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                              | www.pragma-pod.nl

More information about the ntg-context mailing list