[NTG-context] debian context updates

Norbert Preining preining at logic.at
Wed Jan 3 09:18:42 CET 2007

HI Sanjoy!

(Taking of Mike, I am not sure whether he is interested in bug reports,
he only gets all my announces since he was the first/most active tester)

On Die, 02 Jan 2007, Sanjoy Mahajan wrote:
> I'm using Ubuntu 6.10, so context_2006.12.27-1_all.deb wouldn't
> install without a --force-conflicts,overwrite,depends given to dpkg
> (Ubuntu still uses tetex 3.0).  With that caveat, which may explain
> the buglet I saw, it mostly worked fine.

Isn't texlive in ubuntu? Maybe not in 6.10. 

Well all the forces are necessary, tetex and context provide some same
files in /usr/bin

> The buglet: The context formats that the package installed in
> /var/lib/texmf/web2c/pdfetex are not found.  For example, "pdfetex
> '&cont-en'" tries to run mktexfmt.  So I made a symlink from

Strange, does your texmf.cnf contain the following TEXFORMAT line:
	TEXFORMATS = .;$TEXMF/web2c/{$engine,}

> /var/lib/texmf/web2c/pdfetex to /var/lib/texmf/web2c/pdftex and then
> 'texexec' worked fine on my current document (a 50-page mathematics
> textbooklet).

(BTW, can you send me this file in private with all support stuff, I
need context test documents, I wont publish it ;-)

> I'm pretty sure the problem arose because I now use pdftex 1.40.0,
> which (I think) sets the engine to pdftex, even when it is called as
> pdfetex.

Umpf, yes. Well. If you prefer to hack everything yourself you have to
expect bad things...

> Not sure what the best solution is.  The symlink is a bit of a hack.

THere is none. Stick with pdf(e)tex as shipped by tetex.

> In the long run, it's good to get rid of the pdfetex/pdftex

This will be in TeX Live 2006...

> engine.  So until all surrounding programs are taught to use pdftex as
> the engine, this problem will occur and maybe the symlink is the
> solution.

All this will go into texlive-* 2006, as there is pdftex 1.40.0

> Before I did the dpkg --force..., I was trying to simulate its effect
> in a custom script.  So I looked through the ctxfmtutil script and was
> surprised to find that this texexec command (on line 38) worked:

No idea about this,

> `Not all those who wander are lost.' (J.R.R. Tolkien)


Best wishes


Dr. Norbert Preining <preining at logic.at>                    Università di Siena
Debian Developer <preining at debian.org>                         Debian TeX Group
gpg DSA: 0x09C5B094      fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
One's never alone with a rubber duck.
                 --- Douglas Adams, The Hitchhikers Guide to the Galaxy

More information about the ntg-context mailing list