[NTG-context] wiki: debian installation

Sanjoy Mahajan sanjoy at mrao.cam.ac.uk
Thu Oct 5 06:47:09 CEST 2006


> >        Warning: pdfetex (file /home/myuser/texmf/fonts/map/dvipdfm/
> >        context/original-base.map): invalid entry for `fmvr8x': font
> >        file missing
> 
> Some time ago it was a hot topic on the mailing list. See:
>    http://wiki.contextgarden.net/Error_Recovery
> and fix it if possible even if it is working now for some reason.

I ran into the same issue a few days ago and eventually found my to
the same solution.  About the 'some reason': I noticed that without
the fix, sometimes it worked, sometimes it didn't.  The answer is the
damn database file (the ls-R).  kpathsea searches in 'directory
order', which you can find with 'ls -U'.  So

   ls -U ~/texmf/fonts/map/

gave me pdfetex, dvips, then dvipdfm, and I couldn't understand why
anyway the dvipdfm file was being found ahead of the pdfetex one (even
without the $progname).  The answer is that the ls-R file is listed
in, well, ls -R order, which is not necessarily directory order.  It's
probably alphabetical.  So dvipdfm is ahead of pdfetex.  Getting rid
of the ls-R means the pdfetex map file is found (good), but it can
easily change back if some script makes a new ls-R (so it's not
robust).

Short version: Do the recommended fix.

-Sanjoy

`Never underestimate the evil of which men of power are capable.'
         --Bertrand Russell, _War Crimes in Vietnam_, chapter 1.


More information about the ntg-context mailing list