[NTG-context] definetypeface vs math symbols

Ralf Schmitt ralf at brainbot.com
Mon Jul 10 12:19:34 CEST 2006

Thomas A. Schmitz wrote:
> On Jul 10, 2006, at 11:01 AM, Ralf Schmitt wrote:
>> I thought about making a comment on this remark. I tried 0pt font  
>> size,
>> didn't work. Then I tried 1pt font size. And the funny thing is:
>> With 1pt font size the output is good!!!(also with 2pt and 3pt, but  
>> not
>> with 4pt or up, with or without the \usetypescript command.).
>> Any insights? Am I going insane?
> OK, this was just a joke, but it might help us. Looks like ConTeXt  
> can't find the math font for defined sizes. Could you try two things  
> (in turn, not at the same time):
> 1. define the math font as well:
> \definetypeface [charter] [mm] [math] [modern] [default] [encoding=ec]
> and see if this solves your problem.

This works.

> 2. In the file $TEXMF/tex/context/user/cont-sys.rme (or cont-sys.tex,  
> if you have that file already), uncomment the line
> \resetmapfiles \usetypescript [map] [base] [all]
> save the file to cont-sys.tex, run texhash (or sudo texhash,  
> depending on your setup) and see if this helps.

This doesn't work.

> Your file compiles fine here, no problem at any size.

I've tested it on 3 machines and it didn't work on any of those (ubuntu 
dapper, debian testing, freebsd).

Many thanks,

- Ralf

More information about the ntg-context mailing list