[NTG-context] Another texmfstart question

gnwiii at gmail.com gnwiii at gmail.com
Mon May 29 13:47:04 CEST 2006

On 5/29/06, Jean Magnan de Bornier <jm.bornier at free.fr> wrote:
> Hi all,
> I just made on my linux-gentoo box a fresh install using (exactly)
> this howto:
> http://wiki.contextgarden.net/TeTeX_3.0_installation
> But using "texmfstart texexec toto" gives "texmfstart not found"; I tried
> with the full path of texmfstart.rb and  get "permission denied"; so I go
> into the directory /usr/local/teTeX/share/texmf-local/scripts/context/ruby
> and see that many scripts are not executable for others (regular users);
> so I say "chmod +x *" in that directory and then "texmfstart texexec toto"
> still doesn't work but it actually works with the full path; however my
> path is correctly set for context afaik.

On my systems, teTeX-3 does not include a texmfstart executable.  One approach
is to copy the texmfstart.rb script to "texmfstart" in a directory on your PATH.

Earlier, I posted a script I have been testing to the list.  The
script uses kpsewhich
to find the .rb or .pl script corresponding to the name used to invoke
the script, and then runs perl or ruby with the full path to the
script.  This saves having to copy the scripts everytime you update

> I tried to set $RUBYLIB to this directory but it doesn't change anything.

RUBYLIB is set in the "setuptex" script from the minimal linux.  For
my simple tasks
it doesn't appear to be needed, but setting it shouldn't hurt.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the ntg-context mailing list