[NTG-context] pdfetex cannot find map files

Aditya Mahajan adityam at umich.edu
Wed May 17 22:32:00 CEST 2006

On Wed, 17 May 2006, Hans Hagen wrote:

> Aditya Mahajan wrote:
>> Yes, I did. I do not keep texmfstart in my path to prevent running
>> context without sourcing setuptex.
>> I also tried this by running, cscite.bat and compiling the file
>> through scite. I get the same error message.
>> Is it possible that the wrong texmf.cnf is loaded (as Taco pointed
>> out). There is one at texmf/web2c also. setuptex sets TEXMFCNF to
>> F:\tmp\mp>echo %TEXMFCNF%
>> E:\isoimage\usr\local\context\tex\texmf{-local,}/web2c
>> I changed that to
>> .......\tex\texmf-local\web2c, but still get the same error.
>> Context can locate the files
>> F:\tmp\mp>texmfstart --locate original-empty.map
>> E:/isoimage/usr/local/context/tex/texmf-local/fonts/map/dvipdfm/context/original
>> empty.map
>> but can not open it. I even tried a chmod 755 -R isoimage, but that
>> did not help.
>> How can I debug why pdfetex is not able to *open* the map files?
> so, since you're running the mswin thing, how come that you have this chmod stuff

Well, I use cygwin to get all the typical unixy tools. But, it seems 
that context (and ruby) do not like cygwin. I need to do some more 
testing to see exactly what was interfering, but removing cygwin from 
the path seems to do the trick.

> (when you are on linux, you can best take the justtex.zip and linuxtex.zip files)

Usually I get along well with cygwin. This is the first time that 
cygwin has bitten me back.


Aditya Mahajan, EECS Systems, University of Michigan
http://www.eecs.umich.edu/~adityam || Ph: 7342624008

More information about the ntg-context mailing list