[NTG-context] pdfetex cannot find map files

Aditya Mahajan adityam at umich.edu
Wed May 17 19:25:14 CEST 2006

On Wed, 17 May 2006, Aditya Mahajan wrote:

>> Aditya Mahajan wrote:
>>> The problem of "cannot open font map file" is still there. I deleted
>>> all existing context trees from my computer and downloaded the
>>> mswincontext.zip (dt. 2006-05-17) from Pragma's website. When I run a
>>> simple
>>> \starttext Hello World \stoptext
>>> file, I get
>>> [log snipped]
> On Wed, 17 May 2006, Hans Hagen wrote:
>> here i get for
>> \starttext test \stoptext:
>>[log snipped]
>> did you run setuptex.bat beforehand?
> Yes, I did. I do not keep texmfstart in my path to prevent running
> context without sourcing setuptex.
> I also tried this by running, cscite.bat and compiling the file
> through scite. I get the same error message.
> Is it possible that the wrong texmf.cnf is loaded (as Taco pointed
> out). There is one at texmf/web2c also. setuptex sets TEXMFCNF to
> F:\tmp\mp>echo %TEXMFCNF%
> E:\isoimage\usr\local\context\tex\texmf{-local,}/web2c
> I changed that to
> .......\tex\texmf-local\web2c, but still get the same error.
> Context can locate the files
> F:\tmp\mp>texmfstart --locate original-empty.map
> E:/isoimage/usr/local/context/tex/texmf-local/fonts/map/dvipdfm/context/original
> empty.map
> but can not open it. I even tried a chmod 755 -R isoimage, but that
> did not help.
> How can I debug why pdfetex is not able to *open* the map files?

Well, there was something in the path that was interfering with 

set PATH=E:\Ruby\bin
E:\isoimage\usr\local\context\tex\setuptex.bat E:\isoimage\usr\local\context\tex

works correctly. I do not know what was interfering, I'll look into 
everything in my path one by one see what was going wrong.

Sorry about all the noise.


More information about the ntg-context mailing list