[NTG-context] New Installation under miktex, not working

Aditya Mahajan adityam at umich.edu
Tue Jan 17 07:23:47 CET 2006

<--- On Jan 16, Mojca Miklavec wrote --->

> Aditya Mahajan wrote:
>> Make a tree called pragma-texmf. Download cont-tmf.zip and
>> cont-fnt.zip and unzip them in pragma-texmf. Go to MikTex options and
>> add pragma-texmf as a tree. Move it up so that it is the first tree.
> /.../
>> This makes me feel whether it is a good idea to have miktex and
>> context for windows (from the pragma site) in parallel. I use cygwin
>> and context for windows only seems to work from cmd.exe and not
>> bash.exe. I tried to convert setuptex.sh to setuptex.bash, but could
>> not get to work. So, I settled with the method of downloading the
>> relevant trees and things work (by black magic, as you said)
> I have them (MikTeX and the stand-alone from Pragma) in parallel
> without any problem. I created "pragmatex.bat" (visible by PATH) which
> calls the setuptex.bat (or whatever the script in the stand-alone
> distr. is called). The two distros don't interfere at all. Once I call
> "pragmatex", all the sources and executables are chosen from the
> stand-alone tree when I compile the documents. (But thanks for the
> idea of making another texmf-pragma tree! I always managed to break
> something when mixing MikTeX and original files from Pragma, that's
> why I preferred to leave things as they are and use another distro
> instead.)

I once again tried to install the standalone context distribution and 
it works :-). So, I deleted context from the miktex distribution and 
now use the standalone distribution. Hopefully, it will be more 
stable than in miktex.

> I'm not sure, but I guess that you would need tetex to run it from
> bash. Don't ask me about the numerous (still unsolved) problems I had
> just because the ruby executable is only available under cygwin at the
> university.

I had a similar problem. I needed cygwin ruby because there are 
certain ruby packages (e.g. narray) that I could get to work with 
cygwin ruby without any hassle but do not work with the ruby one click 
installer. But cygwin ruby and context do not go together. I was 
actually following your thread on comp.lang.ruby hoping that someone 
will come up with a solution, but no suggestion worked. What I finally 
did was, download and install the one click installer, but removed it 
from the PATH. So when I am working on other projects, I get the 
cygwin ruby which works fine. I added a line to setuptex.bat that adds 
the one-click windows ruby to the front of the path. So when a context 
program asks for a ruby, it gets the windows version and everything 
works fine. The only drawback is that I can not use rxvt+bash, and 
have to use cmd.exe

Aditya Mahajan, EECS Systems, University of Michigan
http://www.eecs.umich.edu/~adityam || Ph: 7342624008

More information about the ntg-context mailing list