[NTG-context] Re: Compiling stops with ...

David Arnold darnold at northcoast.com
Sun Nov 20 19:45:39 CET 2005


Gerben, Taco,

OK, I am using Gerben's Context Updated with a beta, so I think  
what's running is the context in texmf.local. I have two type-tmf.dat.

lm $ locate type-tmf.dat
/usr/local/teTeX/share/texmf.local/context/data/type-tmf.dat
/usr/local/teTeX/share/texmf.tetex/context/data/type-tmf.dat
lm $

Does it matter which of these I use?

Before I run "texfont --encoding=texnansi --batch type-tmf.dat," two  
things:

1. How do I figure out whether to set TEXMFMAIN or TEXMFDIST? That  
is, how can I tell where these environment variables point?

2. I could cut and paste in type-tmf.dat, but can I do it with one  
line in the file type-tmf.dat somehow? What would be the line I would  
add near the top of the file?


On Nov 20, 2005, at 12:17 AM, Taco Hoekwater wrote:

>
> Hi David,
>
> Gerben Wierda wrote:
>
>> Hans? Taco?
>> G
>>
>>> From: David Arnold <darnold at northcoast.com>
>>>
> ...
>
>>> Where I am in the current directory with all of the source  
>>> files.  Compiling stops with a font problem:
>>>
>>> (/usr/local/teTeX/share/texmf.local/tex/context/base/type-  
>>> akb.tex))  kpathsea: Running mktextfm texnansi-uplr8a
>>>
>
> It is the same problem I ran into when trying to compile
> the manuals from the subversion repository: you don't have
> the needed metric files on your system.
>
> When I asked Hans, he said:
>
> Just run "texfont --encoding=texnansi --batch type-tmf.dat"
>
> and that worked fine after a little bit of joggling
> with the TEXMFMAIN variable: this variable needs to point
> to the texmf tree that contains the afm files for the
> fonts, and on my system (teTeX 3) that is TEXMFDIST,
> not TEXMFMAIN. The easiest fix was to manually edit
> type-tmf.dat
>
> Greetings, Taco
>
>
>
>

David




More information about the ntg-context mailing list