[NTG-context] font problems again

Hans van der Meer hansm at science.uva.nl
Sun Nov 13 22:35:04 CET 2005


With the last release of context the problem of not getting cm fonts  
is over. These are now found.

However, other font selections bring new difficulties.
I tried various combinations but did not succeed.
The simple program (using TeXShop):

\starttext
\setupbodyfont[tim,12pt]
hello world
\stoptext

Fails and aborts with:
This is pdfeTeX, Version 3.141592-1.30.4-2.2 (Web2C 7.5.5)
ConTeXt  ver: 2005.11.11  fmt: 2005.11.13  int: english  mes: english
....
! Font \*times12ptrmtf*:=utmr8t at 12.0pt not loadable: Metric (TFM)  
file not found.

Changing into \usetypescript[phv]\setupbodyfont[phv,12pt]
! Font \*postscript12ptrmtf*:=utmr8t at 12.0pt not loadable: Metric  
(TFM) file not found.

No help from enabling in cont-sys.tex of:
\usetypescript[adobekb] [\defaultencoding]
(updmap.cfg contains URWkb for the LW35 fonts)
then it starts asking for (non-existing) maps like:
Warning: pdfetex (file ec-urw-helvetica.map): cannot open font map file

If I use
\setupbodyfont[lbr,12pt]
then I get just lm-roman, although I have the YandY lucida fonts  
installed with their original YandY names (lb--.pfb)
Here no help from changing between texnansi and ec default encoding.

Any idea whats amiss? I ran this on a teTeX3 install with the context  
files unzipped into texmf-local.
(I must confess I am tempted to give up on ConTeXt altogether,  
because of these many font troubles.)

Hans van der Meer




More information about the ntg-context mailing list