[NTG-context] cont 2005.10.27 & t5-lmtt10 font problem

VnPenguin vnpenguin at gmail.com
Tue Nov 1 22:45:42 CET 2005


Hi all,
Just updated cont-2005.10.27 on teTeX 3.0 (build from tarball). I
updated package "cont-lmt.zip" from http://www.pragma-ade.com. I
follow step by step at page
http://wiki.contextgarden.net/TeTeX_3.0_installation.

Now I have:

$ texexec --version

 TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005

               texexec : TeXExec 5.4.3 - ConTeXt / PRAGMA ADE 1997-2005
               texutil : TeXUtil 9.0.0 - ConTeXt / PRAGMA ADE 1992-2004
                   tex : pdfeTeX, 3.141592-1.30.4-2.2 (Web2C 7.5.5)
               context : ver: 2005.10.27
               cont-en : ver: 2005.10.27  fmt: 2005.11.1  mes: english

        total run time : 1 seconds


I do a small test with vietnamese utf-8:

----------- begin test ----------------------------------
\language[vn]
\mainlanguage[vn]

\setuptyping
    [style={\switchtobodyfont[10pt]\tt}]

\enableregime[utf]
\setupencoding[default=t5]
\setupbodyfont[reset]

\usetypescript[berry][t5]
\usetypescript[palatino][t5]
\setupbodyfont[palatino,12pt]

\starttext
Giả sử bạn có một loạt khá nhiều

\setuptyping[option=PERL]

\starttyping
use OpenOffice::OODoc;
# Giả sử bạn có một loạt khá nhiều
if ((@ARGV <1) or (@ARGV > 2)){
  print << "EOF";
  Usage: blahblah
EOF
\stoptyping

\stoptext
------------- end of test ------------------------------

On screen I see:
...
systems         : begin file test at line 18
(/work/apps/tetex/share/texmf-dist/tex/context/base/verb-pl.tex
loading         : Context Support Macros / Pretty PERL Verbatim
) (/work/apps/tetex/share/texmf-dist/tex/context/base/pdfr-ec.tex)
fonts           : needs map file: original-base
fonts           : needs map file: ec-public-lm
fonts           : needs map file: ec-base
fonts           : needs map file: t5-base
fonts           : needs map file: t5-urw-palatino
fonts           : needs map file: original-youngryu-px
fonts           : needs map file: t5-public-lm
[1.1{/home/quy/.texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
systems         : end file test at line 32
kpathsea: Running mktexpk --mfmode / --bdpi 72 --mag 1+5/72 --dpi 77 t5-lmtt10
mktexpk: don't know how to create bitmap font for t5-lmtt10.
kpathsea: Appending font creation commands to missfont.log.
 )
Warning: pdfetex (file t5-lmtt10): Font t5-lmtt10 at 77 not found
kpathsea: Running mktexpk --mfmode / --bdpi 72 --mag 1+5/72 --dpi 77 t5-lmtto10
mktexpk: don't know how to create bitmap font for t5-lmtto10.

Warning: pdfetex (file t5-lmtto10): Font t5-lmtto10 at 77 not found
{/work/apps/tetex/share/texmf-local/fonts/enc/dvips/vntex/t5.enc}</work/apps/te
tex/share/texmf-dist/fonts/type1/public/urwvn/uplr8v.pfb>
Output written on test.pdf (1 page, 17698 bytes).
Transcript written on test.log.
...

PDF output is very strange: all font in typing mode are lossed !
(see screenshot:
http://people.vnoss.org/~vnpenguin/pub/shots/cont-font-problem.png)
PDF of the test is : http://people.vnoss.org/~vnpenguin/pub/test.pdf

I missed some thing when updating ?

Thank you in advance,

Quy NGUYEN-DAI
--
http://vnoss.org
Vietnamese Open Source Software Community


More information about the ntg-context mailing list